PAT 甲 1009 Product of Polynomials

这篇博客介绍了一个C++程序,用于实现两个多项式的乘法。程序通过存储每个项的指数和系数,然后进行合并同类项来完成乘法操作。在处理过程中特别考虑了指数为0和系数为0的情况,并确保结果准确到小数点后一位。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​ N2​ aN2​ … NK​ aNK
​​
​​ where K is the number of nonzero terms in the polynomial, Ni
​​ and aNi​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK​ <⋯<N2​ <N1​ ≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

首先将两组数读入,然后进行多项式乘法,我用的方法是不存储指数的相关系数,而是直接存储整个项,再进行合并同类项。要注意的是指数为0的情况,以及系数为0的情况,在合并同类项的时候,系数为0的项不用输出。

#include<iostream>
#include<cstdio>
using namespace std;

struct num{
	long index;
	double coe;
};

int main(){
	num a[11],b[11],c[101]={0};
	long n,m,k=0,t=0,max=0,p;
	cin>>n;
	for (long i=0;i<n;i++){
		cin>>a[i].index>>a[i].coe;
	}
	cin>>m;
	for (long i=0;i<m;i++){
		cin>>b[i].index>>b[i].coe;
	}
	for (long i=0;i<n;i++)
		for (long j=0;j<m;j++){
			c[k].index=a[i].index+b[j].index;
			c[k].coe=a[i].coe*b[j].coe;
			k++;
		}
	
	for (long i=0;i<k;i++)
		for (long j=i+1;j<k;j++){
			if (c[i].index==c[j].index){
				c[i].coe+=c[j].coe;
				c[j].coe=c[j].index=-1; 
			}
		}
	for (long i=0;i<k;i++)
		if (c[i].index!=-1&&c[i].coe!=0) t++;
	cout<<t;
	
	while (t--){
		max=-1;
		for (long i=0;i<k;i++)
			if (c[i].index>max&&c[i].index!=-1&&c[i].coe!=0){
				max=c[i].index;
				p=i;
			}
		c[p].index=-1;
		printf(" %ld %.1lf",max,c[p].coe);
		
	}
	
	cout<<endl;
	return 0;
}

欢迎指导和交流!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值