Sum Problem
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
Author
DOOM III
Code
import java.io.BufferedInputStream;
import java.util.Scanner;
public class Main {
private static Scanner in = new Scanner(new BufferedInputStream(System.in));
public static void main(String[] args) {
while (in.hasNext()) {
int i = in.nextInt();
int s = 0;
for(int j = 1; j <= i; j++) {
s += j;
}
System.out.println(s);
System.out.println();
}
}
}
Result
Run ID | Submit Time | Judge Status | Pro.ID | Exe.Time | Exe.Memory | Code Len. | Language | Author |
---|---|---|---|---|---|---|---|---|
24605141 | 2018-05-02 00:44:21 | Accepted | 1001 | 280MS | 9616K | 405 B | Java | pyjcak |