[ACM]POJ1163 The Triangle

本文介绍了一个经典的DP(动态规划)问题——数字三角形的最大路径和。通过两种不同的算法实现了解决方案,第一种使用递归的方式,第二种采用了自底向上的动态规划方法,对比了两者的优劣。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

DP 数字三角形

Description

........7
......3   8
....8   1   0
..2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

这道题咋一看挺简单,最容易想到的是采用递归,遍历若有的路径,对所有的路径求和,然后求出最大值,代码如

下:

#include <stdio.h>
#include <iostream>

using namespace std;
int sum = 0;
int rows;
int num[100][100] = {0};

void f(int s,int i, int j)
{
	s += num[i][j];
	if(i == rows - 1)
	{
		if(s > sum)
			sum = s;
		return;
	}
	f(s,i+1,j);
	f(s,i+1,j+1);
}

int main()
{
	freopen("in.txt","r",stdin);
	int i,j;
	cin>>rows;
	for (i = 0; i < rows; i++)
		for (j = 0; j <= i; j++)
			cin>>num[i][j];
	f(0,0,0);
	cout<<sum<<endl;
	return 0;
}

然而,递归终究不是最理想的解法,无论从时间复杂度还是从空间复杂度都不是最理想的选择,我们可以换一种思

维,“自底向上”逐个比较最大值,从倒数第二层开始,用下一层子节点的最大值与本节点相加,“逆流而上”,见

代码:

#include <stdio.h>
#include <iostream>

using namespace std;

int main()
{
	int sum = 0;
	int rows;
	int num[100][100] = {0};
	freopen("in.txt","r",stdin);
	int i,j;
	cin>>rows;
	for (i = 0; i < rows; i++)
		for (j = 0; j <= i; j++)
			cin>>num[i][j];
	
	for (i = rows - 1; i >= 0; i--)
		for (j = 0; j <= i; j++)
			num[i][j] += num[i+1][j] > num[i+1][j+1] ? num[i+1][j] : num[i+1][j+1];
	cout<<num[0][0]<<endl;
	return 0;
}

呵呵,代码量是不是少了很多,而且时间复杂度和空间复杂度都降低了!(第二种解法来源于网上,感谢原作者)


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值