给定一个完全由小写英文字母组成的字符串等差递增序列,该序列中的每个字符串的长度固定为 L,从 L 个 a 开始,以 1 为步长递增。例如当 L 为 3 时,序列为 { aaa, aab, aac, …, aaz, aba, abb, …, abz, …, zzz }。这个序列的倒数第27个字符串就是 zyz。对于任意给定的 L,本题要求你给出对应序列倒数第 N 个字符串。
输入格式:
输入在一行中给出两个正整数 L(2 ≤ L ≤ 6)和 N(≤105)。
输出格式:
在一行中输出对应序列倒数第 N 个字符串。题目保证这个字符串是存在的。
输入样例:
3 7417
输出样例:
pat
#include<iostream>
#include<stack>
#include<cmath>
#include<cstdio>
using namespace std;
stack<int>s;
void A_to_B(int A,int L)
{
int sum=pow(26,L);
int B=sum-A;
while(!s.empty())s.pop();
int i=0;
while(i<L)
{
s.push(B%26);
B/=26;
i++;
}
}
int main()
{
int L,A;
cin>>L>>A;
A_to_B(A,L);
while(!s.empty())
{
char t=s.top()+'a';
cout<<t;
s.pop();
}
cout<<endl;
}