2017杭电多校联赛第二场-Maximum Sequence(hdu6047)

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}:  an+1a2n . Just like always, there are some restrictions on  an+1a2n : for each number  ai , you must choose a number  bk  from {bi}, and it must satisfy  ai ≤max{ aj -j│ bk ≤j<i}, and any  bk  can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo  109 +7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo  109 +7。
 

Sample Input
  
  
4 8 11 8 5 3 1 4 2
 

Sample Output
  
  
27
Hint
For the first sample: 1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
我们先来解释样例:对于8 11 8 5,我们先用aj-j化一下变为了7 9 5 1,因为7比9小,所以我们用9来替换掉7,
然后后面不变,序列变为9 9 5 1 取第一个数9,然后后面需要填一个数9,划一下9-5=4,所以后面跟着的是4,序
列为9 5 1 4 ,因为1比4小,所以我们用4来替换掉1,序列变 为9 5 4 4 ,然后我们取第一个数9,然后需要后
面填一个数9,划一下9-6=3,所以序列变为了5 4 4 3,不需要更新处理,取第一个数5,然后 后面需要填一个9,
划一下9-7=2,所以序列为4 4 3 2,取第一数4,至此已经取了n=4个数了,所以将取到的数相加9+9+5+4=27。
下面是ac代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a[500004],b[500004];
int n;
long long  modx=1e9+7;
int main()
{
    while(~scanf("%d",&n))
    {
        int k;
        for(int i=1;i<=n;i++)
        {
            a[i]=0;
            b[i]=0;
            scanf("%d",&a[i]);
            a[i]=a[i]-i;
        } 
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&k);
            b[k]++; 
        }
        int yu=a[n],yi=n;
        for(int i=n-1;i>=1;i--)
        {
            if(a[i]<yu)
            {        
                b[yi]+=b[i];
                b[i]=0;
            }
            else
            {
                yu=a[i];
                yi=i;
            }
        }
        int l=n;
        long long sum=0;
        int i=1;
        while(1)
        {
            if(l==n+n)
            break;
            if(b[i]>0)
            {
                l++;
                a[l]=a[i]-l;
                b[l]=1;
                b[i]--;
                yu=a[l];
                yi=l;
                for(int j=l-1;j>=1;j--)
                {
                    if(a[j]<yu)
                   {
                     b[yi]+=b[j];
                     b[j]=0;
                   }
                  else
                    break;
                }
                sum=(sum+a[i]+modx)%modx;
                sum%=modx;
            }
            else
            i++;
        }
        printf("%lld\n",sum);
    }
    return 0;
}

题目链接: 点击打开链接http://acm.hdu.edu.cn/showproblem.php?pid=6047
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值