hdoj-1040-As Easy As A+B(解题报告)

这篇博客是关于HDU 1040题目的解题报告,题目类型为简单的A+B问题。博主详细介绍了问题描述、输入输出格式,并给出了样例输入和输出。解题策略是通过交换排序法,对每组数据进行排序,如果后一个数小于前一个数,则两者交换位置。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1040

问题描述:

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61329    Accepted Submission(s): 26366


Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

  
  
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9

Sample Output

  
  
1 2 3 1 2 3 4 5 6 7 8 9

Author

lcy

题目分析:给出多组数据,每组数据有N个数,分别将每组数据从小到大排序。

解题思路:交换排序。若后一个数比前一个数小,则两数交换。

代码实现:

#include<stdio.h>
int main (void)
{
    int T,N,i,j,t;
    int a[1010];
    scanf("%d",&T);
    while(T--)
    {
       scanf("%d",&N);
       for(i=0;i<N;i++)
           scanf("%d",&a[i]);
       for(i=0;i<N-1;i++)
       {
           for(j=i+1;j<N;j++)
              if(a[i]>a[j])
              {
                t=a[i];
                a[i]=a[j];
                a[j]=t;
              }
       }
       for(i=0;i<N;i++)
       {
           if(i==0)
              printf("%d",a[i]);
           else
              printf(" %d",a[i]);
       }
      printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值