poj2955 Brackets (区间dp)

本文深入探讨了嵌入式硬件与软件开发领域的关键技术和实践,包括单片机、微处理器架构、通信接口等核心知识点,旨在为开发者提供全面的技术指导和深入的理解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3571 Accepted: 1847

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source




#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 105

char a[N];
int dp[N][N];

int main()
{
	while(scanf("%s",a)&&a[0]!='e')
	{
		 memset(dp,0,sizeof(dp));
		 int len=strlen(a);
		 for(int i=len-1;i>=0;i--)
			for(int j=i+1;j<len;j++)
		 {
		 	dp[i][j]=dp[i+1][j];
		 	for(int k=i+1;k<=j;k++)
				if(a[i]=='('&&a[k]==')'||a[i]=='['&&a[k]==']')
				  dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k][j]+2);
		 }
		 printf("%d\n",dp[0][len-1]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值