POJ1797 Heavy Transportation(Dijkstra改写)

本文探讨了如何使用算法解决城市运输问题,通过优化Dijkstra算法,找到从城市1到城市n的最大允许载重量路径。包括算法实现、输入输出规范及示例解析。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目链接:http://poj.org/problem?id=1797


Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 19104 Accepted: 5108

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4


题意:有n个城市和m条路,保证连通,求出从城市1到城市n的一条路径,使得这条路上权值最小的路权值最大。


改写Dijkstra,将i到j的最短路定义为1到j的路径上最小的权值,然后每次从中取最大的作为新起点进行扩展,最后dis[n]即为答案。


由于Dijkstra打得太多思维僵化,总是会出现一些因为的习惯引起的错误。。ORZ


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

int g[1005][1005],dis[1005],vis[1005],n,m;

void dijkstra(int s)
{
     for (int i=1;i<=n;i++)//初始化为原来的最小权值
     {
         dis[i]=g[s][i];
     }
     memset(vis,0,sizeof(vis));
     vis[s]=1;
     for (int i=1;i<=n;i++)
     {
         int ma=-1;
         for (int j=1;j<=n;j++)//要先选出最大值,再更新
         {
             if (vis[j]==0&&dis[j]>ma) {ma=dis[j];s=j;}
         }
         vis[s]=1;
         for (int j=1;j<=n;j++)
         {
             if (vis[j]==0&&dis[j]<min(dis[s],g[s][j])) dis[j]=min(dis[s],g[s][j]);
         }
     }
}

int main()
{
    int T,cas=0;
    scanf("%d",&T);
    while (T--)
    {
          memset(g,0,sizeof(g));
          scanf("%d%d",&n,&m);
          for (int i=0;i<m;i++)
          {
              int a,b,c;
              scanf("%d%d%d",&a,&b,&c);
              g[a][b]=c;g[b][a]=c;
          }
          dijkstra(1);
          printf("Scenario #%d:\n",++cas);
          printf("%d\n\n",dis[n]);//注意格式I
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值