题目链接:http://poj.org/problem?id=1113
Wall
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 28199 | Accepted: 9415 |
Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.
The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.
The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.
Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.
Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
Sample Input
9 100 200 400 300 400 300 300 400 300 400 400 500 400 500 200 350 200 200 200
Sample Output
1628
Hint
结果四舍五入就可以了
题意:一个由n个点组成的城堡,要求建造围墙,与城堡之间的距离要大于L,求围墙最小的周长。
很显然距离要等于L才会最小。观察图形可以发现,围墙的周长即为n个点的凸包周长加上以L为半径的圆的周长。
用Andrew算法求出凸包,然后计算凸包的周长与圆的周长之和即为答案。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
using namespace std;
struct point
{
double x,y;
point(){}
point(double _x,double _y)
{
x=_x;y=_y;
}
point operator - (const point &b) const
{
return point(x-b.x,y-b.y);
}
bool operator < (const point &b) const
{
return x<b.x||x==b.x&&y<b.y;
}
double len()
{
return sqrt(x*x+y*y);
}
}res[1005],p[1005];
const double pi=acos(-1.0);//π的值
int n,l;
double dis(point a,point b)
{
return (a-b).len();
}
double cross(point a,point b)
{
return a.x*b.y-b.x*a.y;
}
int andrew()//Andrew凸包,返回凸包中点的个数
{
sort(p,p+n);
int m=0;
for (int i=0;i<n;i++)
{
while (m>1&&cross(res[m-1]-res[m-2],p[i]-res[m-2])<0) --m;
res[m++]=p[i];
}
int k=m;
for (int i=n-2;i>=0;--i)
{
while (m>k&&cross(res[m-1]-res[m-2],p[i]-res[m-2])<0) --m;
res[m++]=p[i];
}
if (m>1) --m;
return m;
}
int main()
{
while (scanf("%d%d",&n,&l)!=EOF)
{
for (int i=0;i<n;i++)
{
scanf("%lf%lf",&p[i].x,&p[i].y);
}
int m=andrew();
res[m]=res[0];
double sum=0;
for (int i=0;i<m;i++)
{
sum+=dis(res[i],res[i+1]);//凸包的周长
}
sum+=2*pi*l;//加上圆的周长
int ans=(int)(sum+0.5);//四舍五入
printf("%d\n",ans);
}
return 0;
}