POJ2318 TOYS(叉乘+二分法)

这是一道计算几何问题,要求解决一个矩形区域被n条线分割后,每个子区域包含的点数。线段保证不相交,且从上至下,点不位于分割线或矩形边界。解决方案可能涉及叉乘判断线段相对位置和二分查找优化搜索过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目链接:http://poj.org/problem?id=2318


TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9753 Accepted: 4654

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题意:一个矩形区域(左上角为x1,y1,右上角为x2,y2),用n条线分割(保证输入顺序从左到右),每条线都从矩形上边至下边,且两两互不相交,因而将矩形划分成了n+1个区域。向区域中放置m个点,最后输出每个区域中各有多少点。(保证没有点正好在分割线上及在矩形区域外)


向量叉乘可以判断两个向量之间的关系。
此处用的是向量p-l与向量u-l之间的关系,若叉乘值小于0,表示点p在直线lu左边,反之则在右边,利用二分快速找到对应的直线,也就求出了落在那个区域。
需要注意的是二分查找不能准确判断出点落在最右边的情况,所以要把t的初值赋为n。

统计结果存在ans数组中,最后输出,注意末尾的换行。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

struct point
{
       int x,y;
       point(){}
       point(int _x,int _y)
       {
                 x=_x;y=_y;
       }
       point operator - (const point &b) const
       {
             return point(x-b.x,y-b.y);
       }
}u[5005],l[5005];

int n,m,x1,y1,x2,y2,ans[5005];

int cross(point a,point b)//叉乘公式
{
    return a.x*b.y-b.x*a.y;
}

int main()
{
    while (scanf("%d",&n)!=EOF&&n!=0)
    {
          scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
          memset(ans,0,sizeof(ans));
          for (int i=0;i<n;i++)
          {
              int uu,ll;
              scanf("%d%d",&uu,&ll);
              u[i]=point(uu,y1);l[i]=point(ll,y2);//将直线的端点转化为point结构
          }
          for (int i=0;i<m;i++)
          {
              point p;
              scanf("%d%d",&p.x,&p.y);
              int h=0,r=n,t=n;//t初值赋为n
              while (h<=r)
              {
                    int mid=(h+r)/2;
                    if (cross(p-l[mid],u[mid]-l[mid])<=0)
                    {
                       t=mid;
                       r=mid-1;
                    }
                    else h=mid+1;
              }
              ++ans[t];
          }
          for (int i=0;i<=n;i++)
          {
              printf("%d: %d\n",i,ans[i]);
          }
          printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值