The Unique MST(次小生成树)

The Unique MST
Time Limit: 1000MS  Memory Limit: 10000K
Total Submissions: 20786  Accepted: 7314

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

 

      题意:

      给出 T 组数组,每组数据给出 N, M,代表有有 N 个节点, M 条无向边,问是否有唯一的一颗最小生成树,有则输出这个值,没有则输出 Not Unique!

 

      思路:

      次小生成树。先用 Prim 算法算出最小生成树,记录最小生成树的边是什么,然后枚举生成树的边,一条条删去,删去后再求一遍生成树,如果所构成的图连通且这个值与原来最小生成树的值相等则输出 Not Unique,如果没有则说明唯一。注意每次都要判断是否连通。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef struct {
    int a, b, num;
} node;

node no[200005];
int root[505], path[505];
int n, m, cnt, sum;

void init() {
    for (int i = 1; i <= n; ++i)
        root[i] = i;
}

int Find (int x) {
    return x == root[x] ? x : root[x] = Find(root[x]);
}

bool cmp (node a, node b) { return a.num < b.num; }

bool test() {
    int num = 0;
    for (int i = 1; i <= n; ++i) {
        if (root[i] == i) ++num;
        if (num > 1) return false;
    }

    return true;
}

bool solve () {
    if (!test()) return false;

    for (int i = 0; i < cnt; ++i) {
        init();

        int ans = 0;
        for (int j = 0; j < m; ++j) {
            if (j == path[i]) continue;

            int A = Find(no[j].a);
            int B = Find(no[j].b);
            if (A != B) {
                ans += no[j].num;
                root[A] = B;
            }
        }
        if (!test()) continue;

        if (ans == sum) return false;
    }

    return true;
}

int main() {

    int t;
    scanf("%d", &t);

    while (t--) {
        scanf("%d%d", &n, &m);


        for (int i = 0; i < m; ++i) {
            scanf("%d%d%d", &no[i].a, &no[i].b, &no[i].num);
        }

        sort(no, no + m, cmp);

        init();
        cnt = sum = 0;
        for (int i = 0; i < m; ++i) {
            int A = Find(no[i].a);
            int B = Find(no[i].b);
            if (A != B) {
                root[A] = B;
                path[cnt++] = i;
                sum += no[i].num;
            }
        }

        if (solve()) printf("%d\n", sum);
        else printf("Not Unique!\n");

    }

    return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值