1065 A+B and C (64bit) (20 分)

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−263,263], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: falseotherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

Analysis

题目大意

给你三个范围在[-2^63, 2^63]的整数a、b、c,判断a+b>c是否成立。

解析

已知long long类型可以表示64位整数,但两数相加会溢出。需要对溢出判断一下。

  1. 一正一负一定不会溢出,所以直接判断a+b>c即可
  2. a为正,b为正,若溢出,则a+b<0,则a+b一定大于c。因为a与b的和早已大于c的取值范围。
  3. a为负,b为负,若溢出则a+b>=0,同理a+b一定小于c。

详见代码。

Code

#include <iostream>
#include <strstream>
#include <vector>
#include <algorithm>
#include <map>
#include <set>
#include <string>
#include <stack>
#include <queue>
#include <cstdio>
#include <cmath>
#include <cstring>

int main () {
	long long a, b, c, res;
	int n, flag;
	
	scanf("%d", &n);

	for (int i = 0; i < n; i++) {
		scanf("%lld%lld%lld", &a, &b, &c);
		res = a+b;
		if(a>0 && b>0 && res<0) flag = 1;
		else if (a < 0 && b < 0 && res >= 0) flag = -1;
		else if (res > c) flag = 1;
		else flag = -1;
		printf("Case #%d: ", i+1);

		if(flag == 1) printf("true\n");
		else printf("false\n");
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值