USACO 1.3 - Barn Repair(贪心)

在风雨交加的夜晚,农夫约翰的牛棚遭遇了屋顶和大门的损坏,导致牛棚内的布局混乱。面对有限的木板数量,他需要在牛棚内快速搭建新的隔板来确保所有有牛的牛棚都得到保护。本文通过实例讲解如何通过数学逻辑和排序算法,以最小化所需木板的数量,从而高效地解决问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

It was a dark and stormy night that ripped the roof and gates offthe stalls that hold Farmer John's cows. Happily, many of the cows wereon vacation, so the barn was not completely full.

The cows spend the night in stalls that are arranged adjacent toeach other in a long line. Some stalls have cows in them; some do not.All stalls are the same width.

Farmer John must quickly erect new boards in front of the stalls,since the doors were lost. His new lumber supplier will supply himboards of any length he wishes, but the supplier can only deliver asmall number of total boards. Farmer John wishes to minimize the totallength of the boards he must purchase.

Given M (1 <= M <= 50), the maximum number of boards that canbe purchased; S (1 <= S <= 200), the total number of stalls; C (1<= C <= S) the number of cows in the stalls, and the C occupiedstall numbers (1 <= stall_number <= S), calculate the minimumnumber of stalls that must be blocked in order to block all the stallsthat have cows in them.

Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1:M, S, and C (space separated)
Lines 2-C+1:Each line contains one integer, thenumber of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18
3
4
6
8
14
15
16
17
21
25
26
27
30
31
40
41
42
43

OUTPUT FORMAT

A single line with one integer that represents the total number of stallsblocked.

SAMPLE OUTPUT (file barn1.out)

25
[One minimum arrangement is one board covering stalls 3-8, one covering14-21, one covering 25-31, and one covering 40-43.]

                                                 

思路:

假设一开始有一大块木板覆盖所有的牛棚,每一次减去最大的空隙,直到分成M快或者没有空隙。

CODE:

/*
ID: sotifis3
LANG: C++
TASK: barn1
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

int c[205], cnt[205];

bool cmp(int x, int y)
{
    return x > y;
}

int main()
{
    //freopen("in", "r", stdin);
    freopen("barn1.in","r",stdin);
    freopen("barn1.out","w",stdout);
    int M, S, C;
    while(~scanf("%d %d %d", &M, &S, &C)){
        memset(cnt, 0, sizeof(cnt));
        for(int i = 0; i < C; ++i){
            scanf("%d", &c[i]);
        }
        sort(c, c + C);
        int ans = c[C - 1] - c[0];
//        printf("%d\n", ans);
        for(int i = 1; i < C; ++i){
            cnt[i - 1] = c[i] - c[i - 1];
        }
        sort(cnt, cnt + C, cmp);
//        for(int i = 0; i < C; ++i){
//            printf("%d ", cnt[i]);
//        }
//        printf("\n");
        for(int i = 0; i < M - 1; ++i){
            ans -= cnt[i];
        }
        printf("%d\n", ans + min(C, M));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值