Leftmost Digit

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13438    Accepted Submission(s): 5159


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.

此题充分利用log来解题,n^n=x -> nlgn=lgx x=10^(nlgn)  ->由此易有nlgn又小数部分和整数部分组成,及可以通过数值的转化来求题,考虑到此题数字较大,我们使用_int64和double来得到小数部分来解题,及通过10^小数得到最高位。


 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
#include <stdio.h>
#include <math.h>
int main()
{
  int i;
  int Case;
  double num;
  int  result;
  double reminder;
  double temp;
  scanf("%d",&Case);
  while(Case--)
  {
    scanf("%lf",&num);
    temp=num*log10(num);
    reminder=temp-(__int64)(temp);
    result=pow(10,reminder);
    printf("%d\n",result);
    }
    return 0;

此题充分利用log来解题,n^n=x -> nlgn=lgx x=10^(nlgn)  ->由此易有nlgn又小数部分和整数部分组成,及可以通过数值的转化来求题,考虑到此题数字较大,我们使用_int64和double来得到小数部分来解题,及通过10^小数得到最高位。


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值