Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:
有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
已经告诉你了,这是个DP的题目,你能AC吗?
有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?
Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
Sample Input
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
#include<stdio.h>
#include<iostream>
#include<math.h>
using namespace std;
int main()
{
int n;
int a;
int b[105][105],c[105][105];
while(scanf("%d",&n)!=EOF)
{
while(n--)
{
int maxn=0;
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
scanf("%d",&a);
for(int i=1;i<=a;i++)
for(int j=1;j<=i;j++)
scanf("%d",&b[i][j]);
c[1][1]=b[1][1];
for(int k=2;k<=a;k++)
for(int t=1;t<=k;t++)
{
c[k][t]=b[k][t]+max(c[k-1][t-1],c[k-1][t]);
}
for(int p=1;p<=a;p++)
{
maxn=max(maxn,c[a][p]);
}
printf("%d\n",maxn);
}
}
return 0;
}
从上向下分析,从下向上求解