Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 128040 Accepted Submission(s): 29659
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
Author
Ignatius.L
Recommend
题目说明:
看到题目的时候,把题目理解错了,一直看不懂题目是什么意思。
后来反复的读题目,原来是这个意思。(就是求和最大子序列)
拿题目中的输入输出例子举例吧:
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
其中,第一行的2:表示下面连续输入两行。
第二行的第一个数 5 :表示这一行后面有5个数字要输入。(我就是这里理解错了)。
第三行的第一个数 7 表示后面有7个数字要输入。(实际数字为:0 6 -1 1 -6 7 -5 ,不包括前面的数字7)
该题我开始用动态规划+数组做的,估计是空间超出限制了,提交了7-8次,一直WA。
后来 无幻的博客 将数组去掉了,AC成功。
这里直接放出链接:http://blog.youkuaiyun.com/akof1314/article/details/4757021
/*
Name: HDU 1003
Copyright: Analyst
Author: Analyst
Date: 04/03/14 19:20
Description: dev-cpp 5.5.3
*/
#include <stdio.h>
int j, t;
int max(int a, int b)
{
return a >= b ? a : (t = j,b); /*临时保存pos1*/
}
int main()
{
int T, N, i, maxValue;
int temp, sum, pos1, pos2;
scanf("%d", &T);
for (i = 0; i < T; ++i)
{
scanf("%d%d", &N, &temp);
pos1 = pos2 = t = 1;
maxValue = sum = temp;
for (j = 2; j <= N; ++j)
{
scanf("%d",&temp);
sum = max(sum+temp,temp); /*如果相加之和小于该数*/
if (sum >= maxValue)
{
maxValue = sum;
if (temp != 0) /*避免情况:5 0 0 1 0 0*/
pos1 = t;
pos2 = j;
}
}
printf("Case %d:\n%d %d %d\n",i+1,maxValue,pos1,pos2);
if (i != T-1)
printf("\n");
}
return 0;
}
10219892 | 2014-03-04 23:20:51 | Accepted | 1003 | 15MS | 256K | 729 B | C++ | Analyst |