Time Limit: 3000MS | Memory Limit: Unknown | 64bit IO Format: %lld & %llu |
Description

Problem G
e-Coins
Input: standard input
Output: standard output
Time Limit: 10 seconds
Memory Limit: 32 MB
At the Department for Bills and Coins, an extension of today's monetary system has newly been proposed, in order to make it fit the new economy better. A number of new so called e-coins will be produced, which, in addition to having a value in the normal sense of today, also have an InfoTechnological value. The goal of this reform is, of course, to make justice to the economy of numerous dotcom companies which, despite the fact that they are low on money surely have a lot of IT inside. All money of the old kind will keep its conventional value and get zero InfoTechnological value.
To successfully make value comparisons in the new system, something called the e-modulus is introduced. This is calculated as SQRT(X*X+Y*Y), where X and Y hold the sums of the conventional and InfoTechnological values respectively. For instance, money with a conventional value of $3altogether and an InfoTechnological value of $4 will get an e-modulus of $5. Bear in mind that you have to calculate the sums of the conventional and InfoTechnological values separately before you calculate the e-modulus of the money.
To simplify the move to e-currency, you are assigned to write a program that, given the e-modulus that shall be reached and a list of the different types of e-coins that are available, calculates the smallest amount of e-coins that are needed to exactly match the e-modulus. There is no limit on how many e-coins of each type that may be used to match the given e-modulus.
Input
A line with the number of problems n (0<n<=100), followed by n times:
- A line with the integers m (0<m<=40) and S (0<S<=300), where m indicates the number of different e-coin types that exist in the problem, and S states the value of the e-modulus that shall be matched exactly.
- m lines, each consisting of one pair of non-negative integers describing the value of an e-coin. The first number in the pair states the conventional value, and the second number holds the InfoTechnological value of the coin.
When more than one number is present on a line, they will be separated by a space. Between each problem, there will be one blank line.
Output
The output consists of n lines. Each line contains either a single integer holding the number of coins necessary to reach the specified e-modulus S or, if S cannot be reached, the string "not possible".
Sample Input:
3
2 5
0 2
2 0
3 20
0 2
2 0
2 1
3 5
3 0
0 4
5 5
Sample Output:
not possible
10
2
解决方案:求分硬币所需硬币最少数,很显然,由dp[k]=dp[k-coin[i]]+1,想到二维的dp[k1][k2]=dp[k1-coin1[i]][k2-coin2[i]]+1;然后求dp[k1][k2]&&k1*k1+k2*k2==s*s的最小dp[k1][k2]。
code:
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[400][400];
const int inf=0x3f3f3f3f;
struct node
{
int x,y;
} N[50];
int main()
{
int t;
int m,S;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&S);
for(int i=0; i<m; i++)
{
scanf("%d%d",&N[i].x,&N[i].y);
}
memset(dp,0x3f,sizeof(dp));
dp[0][0]=0;
int Min=inf;
for(int i=0; i<m; i++)
{
for(int k1=N[i].x; k1<400; k1++)
{
for(int k2=N[i].y; k2<400; k2++)
{
dp[0][0]=0;
if(dp[k1-N[i].x][k2-N[i].y]<inf)///这个判断非常重要,若dp[k1-N[i].x][k2-N[i].y]>=inf就不要把它的状态转移到dp[k1][k2]上了
dp[k1][k2]=dp[k1-N[i].x][k2-N[i].y]+1;
if(k1*k1+k2*k2==S*S&&dp[k1][k2]<inf)
{
if(dp[k1][k2]<Min)
{
Min=dp[k1][k2];
}
}
}
}
}
if(Min<inf)
printf("%d\n",Min);
else
{
printf("not possible\n");
}
}
return 0;
}