Popular Cows+求强联通量简单题+tarjan算法+POJ

Popular Cows
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23066 Accepted: 9451

Description

Every cow's dream is to become the most popular cow in the herd. In a herd of N (1 <= N <= 10,000) cows, you are given up to M (1 <= M <= 50,000) ordered pairs of the form (A, B) that tell you that cow A thinks that cow B is popular. Since popularity is transitive, if A thinks B is popular and B thinks C is popular, then A will also think that C is 
popular, even if this is not explicitly specified by an ordered pair in the input. Your task is to compute the number of cows that are considered popular by every other cow. 

Input

* Line 1: Two space-separated integers, N and M 

* Lines 2..1+M: Two space-separated numbers A and B, meaning that A thinks B is popular. 

Output

* Line 1: A single integer that is the number of cows who are considered popular by every other cow. 

Sample Input

3 3
1 2
2 1
2 3

Sample Output

1

解决方案:先求强连通分量,缩点,反向建图,求入度为0的点。

code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<stack>
#define MMAX 10003
using namespace std;
int low[MMAX],dfn[MMAX],instack[MMAX];
int in[MMAX];
int fa[MMAX],cnt[MMAX];
int index;
stack<int>S;
vector<int>Map[MMAX];
int N,M;
void init()
{
    index=0;
    memset(cnt,0,sizeof(cnt));
    memset(instack,0,sizeof(instack));
    memset(in,0,sizeof(in));
    for(int i=0; i<=N; i++)
    {
        fa[i]=i;
        Map[i].clear();
    }
    while(!S.empty())
        S.pop();

}
void tarjan(int u)
{
    low[u]=dfn[u]=index++;///时间戳
    S.push(u);
    instack[u]=1;
    int len=Map[u].size();
    for(int i=0; i<len; i++)
    {
        int v=Map[u][i];
        if(!instack[v])
        {
            tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else if(instack[v]==1)
        {
            low[u]=min(low[v],low[u]);
        }
    }
    if(dfn[u]==low[u])
    {
        while(!S.empty())
        {
            int temp=S.top();
            S.pop();
            fa[temp]=u;
            instack[temp]=2;
            if(temp==u) break;
        }

    }

}
int main()
{
    while(~scanf("%d%d",&N,&M))
    {
        init();
        for(int i=0; i<M; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            Map[a].push_back(b);
        }
        for(int i=1; i<=N; i++)
        {
            if(!instack[i])
            {
                tarjan(i);
            }
        }
        for(int i=1; i<=N; i++)
        {
            int len=Map[i].size();
            for(int j=0; j<len; j++)
            {
                int v=Map[i][j];
                if(fa[v]!=fa[i])
                {
                    in[fa[i]]++;
                }
            }
        }
        int _sum=0,ss=0;
        int pre=-1;
        for(int i=1; i<=N; i++)
        {
            if(!in[fa[i]])
            {
                if(pre!=-1&&pre!=fa[i]) ss++;
                _sum++;
                pre=fa[i];
            }

        }
        if(!ss)
            printf("%d\n",_sum);
        else printf("0\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值