Accept: 122 Submit: 330
Time Limit: 1000 mSec Memory Limit : 32768 KB
Problem Description
For each prefix with length P of a given string S,if
S[i]=S[i+P] for i in [0..SIZE(S)-p-1],
then the prefix is a “period” of S. We want to all the periodic prefixs.
Input
Input contains multiple cases.
The first line contains an integer T representing the number of cases. Then following T cases.
Each test case contains a string S (1 <= SIZE(S) <= 1000000),represents the title.S consists of lowercase ,uppercase letter.
Output
For each test case, first output one line containing "Case #x: y", where x is the case number (starting from 1) and y is the number of periodic prefixs.Then output the lengths of the periodic prefixs in ascending order.
Sample Input
4oooacmacmacmacmacmafzufzufzufstostootssto
Sample Output
Case #1: 31 2 3Case #2: 63 6 9 12 15 16Case #3: 43 6 9 10Case #4: 29 12
解决方案:首先,整条串必须要有。然后把整串的所以前缀求出来,用串长减去前缀的长度即为其余的答案
code:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
#define MMAX 1000004
using namespace std;
char text[MMAX];
int next[MMAX];
void get_next()
{
next[0]=-1;
int j=-1,i=0;
while(text[i]!='\0')
{
if(j==-1||text[i]==text[j])
{
i++,j++;
next[i]=j;
}
else j=next[j];
}
}
int main()
{
int t,k=0;
scanf("%d",&t);
while(t--)
{
scanf("%s",text);
int len=strlen(text);
get_next();
stack<int> S;
S.push(len);
int j=len;
while(next[j]>=1)
{
j=next[j];
S.push(j);
}
printf("Case #%d: %d\n",++k,S.size());
j=len;
while(next[j]>=1)
{
j=next[j];
printf("%d ",len-j);
}
printf("%d\n",len);
}
return 0;
}