Knights in FEN +uva+bfs

Problem D

Knights in FEN

Input: standard input

Output: standard output

Time Limit: 10 seconds

 

There are black and white knights on a 5 by 5 chessboard. There are twelve of each color, and there is one square that is empty. At any time, a knight can move into an empty square as long as it moves like a knight in normal chess (what else did you expect?).

Given an initial position of the board, the question is: what is the minimum number of moves in which we can reach the final position which is:

Input

First line of the input file contains an integer N (N<14) that indicates how many sets of inputs are there. The description of each set is given below:

Each set consists of five lines; each line represents one row of a chessboard. The positions occupied by white knights are marked by 0 and the positions occupied by black knights are marked by 1. The space corresponds to the empty square on board.

There is no blank line between the two sets of input.

The first set of the sample input below corresponds to this configuration:

Output

For each set your task is to find the minimum number of moves leading from the starting input configuration to the final one. If that number is bigger than 10, then output one line stating

Unsolvable in less than 11 move(s).

 

otherwise output one line stating

Solvable in n move(s).

where n <= 10.

The output for each set is produced in a single line as shown in the sample output.

Sample Input

2
01011
110 1
01110
01010
00100
10110
01 11
10111
01001
00000

Sample Output

Unsolvable in less than 11 move(s).
Solvable in 7 move(s).
解决方案:想到了bfs,可是不知道怎么标记搜过的点的状态,后面看了人家的代码才知,可用string和map。
代码:
#include<iostream>
#include<cstdio>
#include<queue>
#include<map>
#include<cstring>
#include<algorithm>
using namespace std;
char matrix[6][6];
struct mat{
char m[30];
int step;
int space;
};
int dir[8][2]={{2,1},{-2,1},{1,2},{1,-2},{-1,2},{-1,-2},{-2,-1},{2,-1}};
char goal[30];
void swap(mat &temp,int st,int en){

   char s=temp.m[st];
   temp.m[st]=temp.m[en];
   temp.m[en]=s;
   temp.space=en;
}
void bfs(mat t){
     queue < mat > Q;
     map<string ,int > hash;
     Q.push(t);
     hash[t.m]=1;
     while(!Q.empty()){
     mat temp=Q.front();

     mat cur=temp;
    // cout<<"sd";

     if(strcmp(temp.m,goal)==0||temp.step>10)
     {

         if(temp.step>10){
         printf("Unsolvable in less than 11 move(s).\n");
         }
         else {
         printf("Solvable in %d move(s).\n",temp.step);
         }
         return ;

     }
     Q.pop();
     int x=temp.space%5;
     int y=temp.space/5;
     for(int i=0;i<8;i++){
     temp=cur;
     int xx=x+dir[i][0];
     int yy=y+dir[i][1];
     if(xx<0||xx>4||yy<0||yy>4) continue;
     int en=yy*5+xx;
    //  cout<<en<<endl;
     swap(temp.m[temp.space],temp.m[en]);

    // cout<<hash[re.m]<<endl;
     if(hash[temp.m]!=1){
      //   cout<<re.m<<endl;
         //getchar();
     hash[temp.m]=1;
     temp.space=en;
     temp.step++;
     Q.push(temp);
     }
     }
     }


}
int main(){
    int t;
    scanf("%d",&t);
    getchar();///之前这个位置放到了循环里面的,查了几小时,郁闷。。。。。
    while(t--){

    for(int i=0;i<5;i++){
    gets(matrix[i]);
    }
    mat temp;
    for(int i=0;i<5;i++)
    for(int j=0;j<5;j++){
    temp.m[i*5+j]=matrix[i][j];
    if(matrix[i][j]==' ')
    temp.space=i*5+j;
    }
    temp.m[25]='\0';
    temp.step=0;
    //char goal[30]="111110111100 110000100000";
    strcpy(goal,"111110111100 110000100000");
    //cout<<goal<<endl;
    bfs(temp);
  //cout<<temp.space<<endl;
    //cout<<temp.m<<endl;

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值