Elevator

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input
1 2 
3 2 3 1
0

Sample Output
17 41


首先明白题目的意思,电梯向上一层花费6秒,向下一层花费4秒,到达指定楼层后在该层停留5秒,每次电梯从 0层出发 根据所给数据到达指示楼层,然后计算所花费的时间,输出总时间。

在看数据时,每行的第一个数据是指这一行有几个要测验的数据,而不是指示楼层,
现在计算一下 3 2 3 1 这组数据,从0-2花费2*6=12,然后停留5秒,继续向上花费6秒,停留5秒,从3-1,向下到1层花费2*4=8,停留5秒,总共12+5+6+5+8+5=41


代码

#include <iostream>
using namespace std;
int main()
{
    int n,a[100],i=0,sum=0;
    while (cin>>n)
    {
        if(n==0)break;
        else
        {
            a[0]=0;
            sum=0;
            for(i=1; i<=n; i++)
                cin>>a[i];
            for (i=1; i<=n; i++)
            {
                if(a[i]>a[i-1])
                    sum=sum+(a[i]-a[i-1])*6+5;
                else
                    sum=sum+(a[i-1]-a[i])*4+5;
            }
            cout<<sum<<endl;
        }
    }
    return 0;


}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值