HDOJ 4786 Fibonacci Tree

这篇博客探讨了Fibonacci Tree的概念,它是解决最大生成树与最小生成树问题的一种经典方法。作者回忆了这道题目在过往竞赛中的重要性。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >


最大生成树夹最小生成树,老题目了,依稀记得当年在成都靠这题捡了个铜。。。。。

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1572    Accepted Submission(s): 479


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=100100;

int nf,fib[100];

int getFib()
{
    fib[0]=1;fib[1]=2;
    nf=2;
    for(int i=2;fib[nf-1]<=100100;i++)
    {
        fib[nf]=fib[nf-1]+fib[nf-2];
        nf++;
    }
}

int n,m;
int fa[maxn];

int find(int x)
{
    if(x==fa[x]) return x;
    return fa[x]=find(fa[x]);
}

struct Edge
{
    int u,v,c;
}edge[maxn];

bool cmp1(Edge x,Edge y)
{
    return x.c<y.c;
}

bool cmp2(Edge x,Edge y)
{
    return x.c>y.c;
}

int Kruscal()
{
    int cnt=n,ans=0;
    for(int i=0;i<=n+1;i++) fa[i]=i;
    for(int i=0;i<m;i++)
    {
        int f1=find(edge[i].u);
        int f2=find(edge[i].v);

        if(f1!=f2)
        {
            fa[f1]=f2;
            ans+=edge[i].c;
            cnt--;
            if(cnt==1) break;
        }
    }
    return (cnt==1)?ans:0x3f3f3f3f;
}

int main()
{
    getFib();
    int T_T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d%d",&n,&m);

        for(int i=0;i<m;i++)
        {
            int a,b,w;
            scanf("%d%d%d",&a,&b,&w);
            edge[i].u=a; edge[i].v=b; edge[i].c=w;
        }
        sort(edge,edge+m,cmp1);
        int MiMST=Kruscal();
        sort(edge,edge+m,cmp2);
        int MxMST=Kruscal();

        bool flag=false;
        for(int i=0;i<nf;i++)
        {
            if(fib[i]>=MiMST&&fib[i]<=MxMST)
            {
                flag=true; break;
            }
        }

        printf("Case #%d: ",cas++);
        if(flag) puts("Yes");
        else puts("No");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值