hdu1536 - S-Nim (博弈 SG函数)

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4120    Accepted Submission(s): 1777


Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.
 

Sample Input
  
  
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output
  
  
LWW WWL
 

Source
 
  //话说读题花了好久的说,英语硬伤啊。。。

题意:
                  输入k,并接着输入k个集合S的元素(设置每次能取的石子数)(0 <k <=100)
                  接着输入m,表示m种情况, (0<m<=100)
                  随后输入m行,每行开头l表示堆数 随后输出hi,表示每堆的石子数 (0<l<=100, 0<=hi<=10000)
                  如果测试用例k = 0,结束程序

                  对于每种情况,如果该情况是胜利点,则输出W,
                  如果是失败点,输出L,每次测试用例结束打印换行

 

//直接套用模版。。。

 

/***************************
*
*	acm:   hdu-1536
*
*	title: S-Nim
*
*	time:  2014.5.8
*
***************************/

//博弈论 考察SG函数


#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXSIZE 1001
#define SET 101

int k;  // 集合S的元素的个数
int S[SET];  //设置每次能取的石子数
int f[10001];   //SG值 f(3) == 1 表示 sg值 == 1

//DFS 求解SG
int mex(int p)  //p 是某堆的石子数  k
{
    int i;
    int t;
    int g[101] = {0};  //记录sg值             

    for (i = 0; i < k; i++)
    {
        t = p - S[i];  //t == 剩余的石子数

        if (t < 0)
        {
            break;
        }

        if (f[t] == -1)
        {
            f[t] = mex(t);
        }

        g[f[t]] = 1;
    }

    for (i = 0; ; i++)
    {
        if (!g[i])   //得到sg值
        {
            return i;
        }
    }
}

int main()
{
    void Sort(int a[], int k);

    while (scanf("%d", &k), k) //逗号表达式最右边的子表达式的值即为逗号表达式的值。
    {
        int i;
        int m;       //m种情况
        int s;       //异或值

        for (i = 0; i < k; i++)
        {
            scanf("%d", &S[i]);
        }

        Sort(S, k);

        memset(f, -1, sizeof(f));
        f[0] = 0;

        scanf("%d", &m);

        while (m--)
        {
            int l;       //每行的堆数
            int t;      //每堆的石子数 hi

            scanf("%d", &l);
            s = 0;

            while (l--)
            {
                scanf("%d", &t);

                if (f[t] == -1)    //如果sg值不存在
                {
                    f[t] = mex(t);  //f[t] 赋予sg值
                }

                s = s^f[t];
            }

            if (s == 0)
            {
                printf("L");
            }
            else
            {
                printf("W");
            }
        }

        printf("\n");
    }
    return 0;
}

//冒泡排序
void Sort(int a[], int K)
{
    int i;
    int j;
    int t;

    for (i = 0; i < K - 1; i++)
    {
        t = i;

        for (j = i + 1; j < K; j++)
        {
            if (a[t] > a[j])
            {
                t = j;
            }
        }

        if (t != i)
        {
            int temp;
            temp = a[t];
            a[t] = a[i];
            a[i] = temp;
        }

    }
}


 


 

 

           

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值