12th浙江省省赛 B题 Beauty of Array

探讨了数组中独特元素的求和,并计算所有连续子数组的和,使用动态规划解决,提供了高效的算法实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Beauty of Array

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21
38
题意:自译吧。
我当时想的是树状数字 学长想的是线段数 (都没想通如何去重复的)
队友用动态 秒过了
思路:

2 3 3 2
:
2 3 3 2
   3 3 2
      3 2
          2
 每次减去之前 
#include<bits/stdc++.h>
using namespace std;
long long sum[1000010];
long long a[100010];
long long b[100010];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(sum,0,sizeof(sum));
        long long n;
        scanf("%lld",&n);
        b[0]=0;
        a[0]=0;
        for(long long i=1;i<=n;i++)
        {
            long long shu;
            scanf("%lld",&shu);
            b[i]=b[i-1]+(i-sum[shu])*shu;
            a[i]=a[i-1]+b[i];
            sum[shu]=i;
        }
        cout<<a[n]<<endl;
    }
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值