POJ 1007 DNA Sorting

                   DNA Sorting

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 87954 Accepted: 35353

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


分析:题目的意思就是找到m个长度为n的DNA序列的逆序数,然后按照逆序数从小到大的顺序将这m个DNA序列稳定排序输出、

稳定排序通俗地讲就是能保证排序前2个相等的数其在序列的前后位置顺序和排序后它们两个的前后位置顺序相同。在简单形式化一下,如果Ai = Aj,Ai原来在位置前,排序后Ai还是要在Aj位置前


#include <iostream>

using namespace std;

struct DNA_Seq
{
    int inverse_num;
    char sequence[50];
};

int get_inverseNum(char seq[],int length)    //求一个序列的逆序数
{
    int num = 0;
    for(int i = 0;i<length;i++)
    {
        if(seq[i] != 'A')
        {
            for(int j = i+1;j<length;j++)
            {
                if(seq[i]>seq[j])
                    num++;
            }
        }
    }
    return num;
}

int main()
{
    int m = 0;
    int n = 0;
    while(cin>>n>>m)
    {
        DNA_Seq *DNA = new DNA_Seq[m];
        for(int i = 0;i<m;i++)
        {
            cin>>DNA[i].sequence;
            DNA[i].inverse_num = get_inverseNum(DNA[i].sequence,n);
        }
        
        for(int i = 0;i<m;i++)      //冒泡排序
        {
            for(int j = i+1;j<m;j++)
            {
                if(DNA[i].inverse_num>DNA[j].inverse_num)
                {
                    DNA_Seq tmp = DNA[i];
                    DNA[i] = DNA[j];
                    DNA[j]= tmp;
                }
            }
        }
        for(int i = 0;i<m;i++)
            cout<<DNA[i].sequence<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值