Billboard
Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7965 Accepted Submission(s): 3530
Total Submission(s): 7965 Accepted Submission(s): 3530
Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3
-1
Author
hhanger@zju
Source
HDOJ 2009 Summer Exercise(5)
Recommend
lcy
题意:给你h*w的木板,每次放进一个1*wi的广告条,尽量让广告条贴在上行,在同一行时靠左贴,每次输出具体贴在了哪一行
思路:线段树的单点更新,每次更新区间最大值,询问完直接更新
本人不解的地方:将下面一处if语句注释掉,再把query中的注释给去掉的代码为什么A不了?哪位大神帮忙解释一下
/*************************************************************************
> File Name: hdu2795.cpp
> Author: BSlin
> Mail:
> Created Time: 2013年09月16日 星期一 22时05分21秒
************************************************************************/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <iterator>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#define MP make_pair
#define INF (1<<30)
#define PI acos(-1.0)
#define esp 1e-8
const int dx[4]={0,0,0,0};
using namespace std;
#define read freopen("in.txt","r",stdin)
#define write freopen("out.txt","w",stdout)
#if defined (_WIN32) || defined (__WIN32) || defined (WIN32) || defined (__WIN32__)
#define LL __int64
#define LLS "%" "I" "6" "4" "d"
#else
#define LL long long
#define LLS "%" "l" "l" "d"
#endif
#define M 200010
int h,w,n,rows;
struct node{
int L,R,max;
}tree[M<<2];
void build(int L,int R,int p){
tree[p].L = L;
tree[p].R = R;
tree[p].max = w;
if(L == R) return ;
int mid = (L + R) >> 1;
build(L,mid,p << 1);
build(mid + 1,R,p << 1 | 1);
}
void up(int p){
tree[p].max = max(tree[p<<1].max,tree[p<<1|1].max);
}
void query(int value,int p){
if(tree[p].L == tree[p].R){
tree[p].max -= value;
printf("%d\n",tree[p].L);
return ;
}
if(tree[p<<1].max >= value) query(value,p<<1);
else if(tree[p<<1|1].max >= value) query(value,p<<1|1);
//else {
//printf("-1\n");
//return ;
//}
up(p);
}
int main(int argc, char** argv) {
//read;
int x;
while(scanf("%d%d%d",&h,&w,&n) != EOF) {
if(h > n) h = n;
build(1,h,1);
for(int i=0;i<n;i++) {
scanf("%d",&x);
if(x>tree[1].max){ //此处if语句
printf("-1\n");
continue;
}
query(x,1);
}
}
return 0;
}