Uncle Tom's Inherited Land*
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1334 Accepted Submission(s): 572
Special Judge
Problem Description
Your old uncle Tom inherited a piece of land from his great-great-uncle. Originally, the property had been in the shape of a rectangle. A long time ago, however, his great-great-uncle decided to divide the land into a grid of small squares. He turned some of the squares into ponds, for he loved to hunt ducks and wanted to attract them to his property. (You cannot be sure, for you have not been to the place, but he may have made so many ponds that the land may now consist of several disconnected islands.)
Your uncle Tom wants to sell the inherited land, but local rules now regulate property sales. Your uncle has been informed that, at his great-great-uncle's request, a law has been passed which establishes that property can only be sold in rectangular lots the size of two squares of your uncle's property. Furthermore, ponds are not salable property.
Your uncle asked your help to determine the largest number of properties he could sell (the remaining squares will become recreational parks).
Your uncle Tom wants to sell the inherited land, but local rules now regulate property sales. Your uncle has been informed that, at his great-great-uncle's request, a law has been passed which establishes that property can only be sold in rectangular lots the size of two squares of your uncle's property. Furthermore, ponds are not salable property.
Your uncle asked your help to determine the largest number of properties he could sell (the remaining squares will become recreational parks).

Input
Input will include several test cases. The first line of a test case contains two integers N and M, representing, respectively, the number of rows and columns of the land (1 <= N, M <= 100). The second line will contain an integer K indicating the number of squares that have been turned into ponds ( (N x M) - K <= 50). Each of the next K lines contains two integers X and Y describing the position of a square which was turned into a pond (1 <= X <= N and 1 <= Y <= M). The end of input is indicated by N = M = 0.
Output
For each test case in the input your program should first output one line, containing an integer p representing the maximum number of properties which can be sold. The next p lines specify each pair of squares which can be sold simultaneity. If there are more than one solution, anyone is acceptable. there is a blank line after each test case. See sample below for clarification of the output format.
Sample Input
4 4 6 1 1 1 4 2 2 4 1 4 2 4 4 4 3 4 4 2 3 2 2 2 3 1 0 0
Sample Output
4 (1,2)--(1,3) (2,1)--(3,1) (2,3)--(3,3) (2,4)--(3,4) 3 (1,1)--(2,1) (1,2)--(1,3) (2,3)--(3,3)
Source
Recommend
LL
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int vis[101][101],n,m;
int link[10010],mark[10010];
vector<int>graph[10010];
bool dfs(int num)
{
int i;
//查找这个点所连接的所有点(点通过push_back进入graph),
for (i=0;i<graph[num].size();i++)//个数由size导出
{
int val=graph[num][i];//graph[num]所链接的第i个点
if (mark[val]==0)//在这次遍历中未被找过
{
mark[val]=1;//标记找过
if(link[val]==-1||dfs(link[val]))//未被连接或则连接这个点的点有增广路
{
link[val]=num;//重新连接
return 1;//成功,匹配数+1
}
}
}
return 0;
}
int hungray()
{
int max_match=0;//最大匹配数
int i;
memset(link,-1,sizeof(link));//连接情况,初始化为-1
for(i=1;i<=n*m;i++)//遍历每个点
{
memset(mark,0,sizeof(mark));//每次遍历前清空标记未0
if(dfs(i))//如果遍历后找得到匹配数+1
max_match++;
}
return max_match;//最终的结果就是最大匹配数
}//二分图模板
int main()
{
int i,j;
while (~scanf("%d%d",&n,&m))
{
if(n==0&&m==0) break;
for (i=1;i<=n*m;i++)
{
graph[i].clear();//使用vector的graph前进行清空
}
memset(vis,0,sizeof(vis));//标记土地使用情况
int r;
scanf("%d",&r);
int a,b;
while(r--)
{
scanf("%d%d",&a,&b);
vis[a][b]=1;//标记pond
}
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)//建图,行列法
{
if(vis[i][j]==0)//这块土地不为pond时
{
if ((i+1)<=n&&vis[i+1][j]==0)//这块土地的下一块可用
{
graph[(i-1)*m+j].push_back(i*m+j);//以先行后列的顺序对土地排序
graph[i*m+j].push_back((i-1)*m+j);//这里相当于(i-1)*m+j<->i*m+j这两点建立匹配边
}
if ((j+1)<=m&&vis[i][j+1]==0)//这块土地的右边一块可用
{
graph[(i-1)*m+j].push_back((i-1)*m+j+1);
graph[(i-1)*m+j+1].push_back((i-1)*m+j);
}
}
}
}
int max_match=hungray();//匈牙利算法
printf("%d\n",max_match/2);//行列法求出的结果要/2
for (i=1;i<=n*m;i++)
{
if (link[i]!=-1&&link[link[i]]!=-1)//i以及link[i]表示这是第几个点
{
int x1,x2,y1,y2;//点的横纵坐标
y1=i%m;//第一个点的纵坐标
if(y1==0)y1=m;
x1=(i-y1)/m+1;//由(i-1)*m+j容易得出
y2=link[i]%m;//第二点同理第一点
if(y2==0) y2=m;
x2=(link[i]-y2)/m+1;
link[i]=link[link[i]]=-1;//避免重复
printf("(%d,%d)--(%d,%d)\n",x1,y1,x2,y2);
}
}
printf("\n");
}
return 0;
}