HDU1507 Uncle Tom's Inherited Land* 解题报告--匈牙利

Uncle Tom's Inherited Land*

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1334    Accepted Submission(s): 572
Special Judge


Problem Description
Your old uncle Tom inherited a piece of land from his great-great-uncle. Originally, the property had been in the shape of a rectangle. A long time ago, however, his great-great-uncle decided to divide the land into a grid of small squares. He turned some of the squares into ponds, for he loved to hunt ducks and wanted to attract them to his property. (You cannot be sure, for you have not been to the place, but he may have made so many ponds that the land may now consist of several disconnected islands.)

Your uncle Tom wants to sell the inherited land, but local rules now regulate property sales. Your uncle has been informed that, at his great-great-uncle's request, a law has been passed which establishes that property can only be sold in rectangular lots the size of two squares of your uncle's property. Furthermore, ponds are not salable property.

Your uncle asked your help to determine the largest number of properties he could sell (the remaining squares will become recreational parks).

 

Input
Input will include several test cases. The first line of a test case contains two integers N and M, representing, respectively, the number of rows and columns of the land (1 <= N, M <= 100). The second line will contain an integer K indicating the number of squares that have been turned into ponds ( (N x M) - K <= 50). Each of the next K lines contains two integers X and Y describing the position of a square which was turned into a pond (1 <= X <= N and 1 <= Y <= M). The end of input is indicated by N = M = 0.
 

Output
For each test case in the input your program should first output one line, containing an integer p representing the maximum number of properties which can be sold. The next p lines specify each pair of squares which can be sold simultaneity. If there are more than one solution, anyone is acceptable. there is a blank line after each test case. See sample below for clarification of the output format.
 

Sample Input
  
  
4 4 6 1 1 1 4 2 2 4 1 4 2 4 4 4 3 4 4 2 3 2 2 2 3 1 0 0
 

Sample Output
  
  
4 (1,2)--(1,3) (2,1)--(3,1) (2,3)--(3,3) (2,4)--(3,4) 3 (1,1)--(2,1) (1,2)--(1,3) (2,3)--(3,3)
 

Source
 

Recommend
LL
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

int vis[101][101],n,m;
int link[10010],mark[10010];
vector<int>graph[10010];

bool dfs(int num)
{
    int i;
	//查找这个点所连接的所有点(点通过push_back进入graph),
    for (i=0;i<graph[num].size();i++)//个数由size导出
    {
        int val=graph[num][i];//graph[num]所链接的第i个点
        if (mark[val]==0)//在这次遍历中未被找过
        {    
            mark[val]=1;//标记找过
            if(link[val]==-1||dfs(link[val]))//未被连接或则连接这个点的点有增广路
            {
                link[val]=num;//重新连接
                return 1;//成功,匹配数+1
            }
        }
    }
    return 0;
}
int hungray()
{
    int max_match=0;//最大匹配数
    int i;
    memset(link,-1,sizeof(link));//连接情况,初始化为-1
    for(i=1;i<=n*m;i++)//遍历每个点
    {
        memset(mark,0,sizeof(mark));//每次遍历前清空标记未0
        if(dfs(i))//如果遍历后找得到匹配数+1
            max_match++;
    }
    return max_match;//最终的结果就是最大匹配数
}//二分图模板
int main()
{
    int i,j;
    while (~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        for (i=1;i<=n*m;i++)
        {
            graph[i].clear();//使用vector的graph前进行清空
        }
        memset(vis,0,sizeof(vis));//标记土地使用情况
        int r;
        scanf("%d",&r);
        int a,b;
        while(r--)
        {
            scanf("%d%d",&a,&b);
            vis[a][b]=1;//标记pond
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)//建图,行列法
            {
                if(vis[i][j]==0)//这块土地不为pond时
                {
                    if ((i+1)<=n&&vis[i+1][j]==0)//这块土地的下一块可用
                    {
                        graph[(i-1)*m+j].push_back(i*m+j);//以先行后列的顺序对土地排序
                        graph[i*m+j].push_back((i-1)*m+j);//这里相当于(i-1)*m+j<->i*m+j这两点建立匹配边
                    }
                    if ((j+1)<=m&&vis[i][j+1]==0)//这块土地的右边一块可用
                    {
                        graph[(i-1)*m+j].push_back((i-1)*m+j+1);
                        graph[(i-1)*m+j+1].push_back((i-1)*m+j);
                    }
                }
            }
        }
        int max_match=hungray();//匈牙利算法
        printf("%d\n",max_match/2);//行列法求出的结果要/2
        for (i=1;i<=n*m;i++)
        {
            if (link[i]!=-1&&link[link[i]]!=-1)//i以及link[i]表示这是第几个点
            {
                int x1,x2,y1,y2;//点的横纵坐标
                y1=i%m;//第一个点的纵坐标
                if(y1==0)y1=m;
				x1=(i-y1)/m+1;//由(i-1)*m+j容易得出
                y2=link[i]%m;//第二点同理第一点
                if(y2==0) y2=m;
				x2=(link[i]-y2)/m+1;
                link[i]=link[link[i]]=-1;//避免重复
                printf("(%d,%d)--(%d,%d)\n",x1,y1,x2,y2);
            }
        }
        printf("\n");
    }
    return 0;
}





标题Python网络课程在线学习平台研究AI更换标题第1章引言介绍Python网络课程在线学习平台的研究背景、意义、国内外现状和研究方法。1.1研究背景与意义阐述Python在线学习平台的重要性和研究意义。1.2国内外研究现状概述国内外Python在线学习平台的发展现状。1.3研究方法与论文结构介绍本文的研究方法和整体论文结构。第2章相关理论总结在线学习平台及Python教育的相关理论。2.1在线学习平台概述介绍在线学习平台的基本概念、特点和发展趋势。2.2Python教育理论阐述Python语言教学的理论和方法。2.3技术支持理论讨论构建在线学习平台所需的技术支持理论。第3章Python网络课程在线学习平台设计详细介绍Python网络课程在线学习平台的设计方案。3.1平台功能设计阐述平台的核心功能,如课程管理、用户管理、学习跟踪等。3.2平台架构设计给出平台的整体架构,包括前后端设计、数据库设计等。3.3平台界面设计介绍平台的用户界面设计,强调用户体验和易用性。第4章平台实现与测试详细阐述Python网络课程在线学习平台的实现过程和测试方法。4.1平台实现介绍平台的开发环境、技术栈和实现细节。4.2平台测试对平台进行功能测试、性能测试和安全测试,确保平台稳定可靠。第5章平台应用与效果分析分析Python网络课程在线学习平台在实际应用中的效果。5.1平台应用案例介绍平台在实际教学或培训中的应用案例。5.2效果评估与分析通过数据分析和用户反馈,评估平台的应用效果。第6章结论与展望总结Python网络课程在线学习平台的研究成果,并展望未来发展方向。6.1研究结论概括本文关于Python在线学习平台的研究结论。6.2研究展望提出未来Python在线学习平台的研究方向和发展建议。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值