HDU1671 Phone List 解题报告--字典树

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7202    Accepted Submission(s): 2471


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

Source
 

Recommend
lcy
 
#include<iostream>
using namespace std;
#include<cstring>
struct node
{
	int count;
	node *next[10];
	node()
	{
		count=0;
		memset(next,0,sizeof(next));
	}
};
node *root=NULL;
void build(char *s) 
{
	node *p=root; 
	int len=strlen(s);
	int i;
	for(i=0;i<len;i++) 
	{   	
		if(p->next[s[i]-'0']==NULL)
		{
			p->next[s[i]-'0']=new node; 
		}
		p=p->next[s[i]-'0'];
		p->count++;//每个节点记录经过次数
	}
}
int find(char *s) 
{
	node *p=root;
	int len=strlen(s);
	int i;
	for(i=0;i<len;i++)
		p=p->next[s[i]-'0'];
	return p->count;//输出这个节点经过次数
}
void freedom(node *p)//释放空间的函数
{
	for(int i=0;i<10;i++)
	{
		if(p->next[i]!=NULL)
			freedom(p->next[i]);//一旦不为空一直释放下去
	}
	free(p);
}
int main()
{
	int r;
	char a[10001][15];
	scanf("%d",&r);
	while(r--)
	{
		root=new node;
		int n;
		scanf("%d",&n);	
		int i,j;
		for(i=0;i<n;i++)
		{
			scanf("%s",a[i]);
			build(a[i]);
		}
		int f=0;
		for(i=0;i<n;i++)//挨个检索号码的可用
		{			
			if(find(a[i])!=1) {f=0;break;}//一旦经过次数不为1则说明重复直接结束答案为NO
			f=1;
		}
		if(f==1)//所有号码无前段重复,可用
			printf("YES\n");
		else
			printf("NO\n");
		freedom(root);//释放空间
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值