Eddy's research II
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2576 Accepted Submission(s): 943
Problem Description
As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.
Ackermann function can be defined recursively as follows:
Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).
Ackermann function can be defined recursively as follows:

Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).
Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.
Input is terminated by end of file.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.
Input is terminated by end of file.
Output
For each value of m,n, print out the value of A(m,n).
Sample Input
1 3 2 4
Sample Output
5 11
大致题意:给你m,n,求出A(m,n)
思路:本来是直接递归,果断TLE,后来优化也不行,无奈看了题解,才明白需要推出递归公式。
A(1,n)=A(0,A(1,n-1))=A(1,n-1)+1 那么可以发现,这个其实是一个等差数列
而且很明显有 A(1,0)=A(0,1)=2,A(1,1)=A(0,A(1,0))=A(1,0)+1=3
那么就可以推出 A(1,n)=n+2
同理可以推出 A(2,n)=2*n+3
A(3,n)=2*A(3,n-1)+3
#include<iostream>
#include <cstdio>
#include<cstring>
#include<algorithm>
#include <cmath>
using namespace std;
int A(int m,int n)
{
if(m==1) return n+2;
if(n==0) return A(m-1,1);
if(m==2) return 2*n+3;
if(m==3) return 2*A(3,n-1)+3;
}
int main()
{
int m,n;
while(~scanf("%d%d",&m,&n))
{
cout<<A(m,n)<<endl;
}
return 0;
}