hdu 1250 Hat's Fibonacci(java大数)

点击打开题目链接

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7407    Accepted Submission(s): 2414


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

用Java写的Fibonacci 数组。

代码:

import java.math.*;
import java.util.*;
public class Main {

    public static void main(String[] args) {
      // TODO Auto-generated method stub
        Integer n,i,N = 9001;
        BigInteger []f = new BigInteger[N];
        f[1] = f[2] = f[3] = f[4] = BigInteger.valueOf(1);
        for(i = 5; i < N; ++i)
            f[i] = f[i-1].add(f[i-2]).add(f[i-3]).add(f[i-4]);
        
        Scanner cin = new Scanner(System.in);
        while(cin.hasNext()){
            n  = cin.nextInt();
            System.out.println(f[n]);
            //System.out.println(f[n].toString().length());
        
        }
        cin.close();
    }

}





HDU1160是一个经典的动态规划问题,题目描述如下: 给定一组老鼠的体重和速度,要求找出最长的老鼠序列,使得序列中每只老鼠的体重和速度都严格递增。 我们可以使用动态规划来解决这个问题。具体步骤如下: 1. 将老鼠按体重或速度排序。 2. 使用动态规划数组`dp`,其中`dp[i]`表示以第`i`只老鼠结尾的最长序列长度。 3. 使用一个数组`pre`来记录每个位置的前驱老鼠,以便最后可以重建序列。 以下是使用Java实现的代码: ```java import java.util.*; class Mouse implements Comparable<Mouse> { int weight, speed, index; Mouse(int weight, int speed, int index) { this.weight = weight; this.speed = speed; this.index = index; } public int compareTo(Mouse other) { if (this.weight != other.weight) { return this.weight - other.weight; } else { return this.speed - other.speed; } } } public class Main { public static void main(String[] args) { Scanner scanner = new Scanner(System.in); List<Mouse> mice = new ArrayList<>(); while (scanner.hasNext()) { int weight = scanner.nextInt(); int speed = scanner.nextInt(); mice.add(new Mouse(weight, speed, mice.size())); } scanner.close(); Collections.sort(mice); int n = mice.size(); int[] dp = new int[n]; int[] pre = new int[n]; int maxLen = 1, endIndex = 0; Arrays.fill(pre, -1); Arrays.fill(dp, 1); for (int i = 1; i < n; i++) { for (int j = 0; j < i; j++) { if (mice.get(i).weight > mice.get(j).weight && mice.get(i).speed > mice.get(j).speed) { if (dp[j] + 1 > dp[i]) { dp[i] = dp[j] + 1; pre[i] = j; } } } if (dp[i] > maxLen) { maxLen = dp[i]; endIndex = i; } } List<Integer> sequence = new ArrayList<>(); while (endIndex != -1) { sequence.add(mice.get(endIndex).index + 1); endIndex = pre[endIndex]; } System.out.println(maxLen); for (int i = sequence.size() - 1; i >= 0; i--) { System.out.println(sequence.get(i)); } } } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值