hdu 1728 逃离迷宫 解题报告

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12848 Accepted Submission(s): 3078


Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input
  
  
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3

Sample Output
  
  
no yes
解题分析
搜索bfs
解题代码
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <queue>
using namespace std;
int m,n,atime,nx,ny;
int vis[200][200];
char map[200][200];
int d[4][2]= {-1,0,1,0,0,-1,0,1};
struct node
{
    int x,y;
    int step;//当前转弯次数
} st,dt,tmp1,tmp2;
int bfs()
{
    if(st.x==dt.x && st.y==dt.y)
        return 1;
    queue<node> q;
    st.step=0;
    memset(vis,0,sizeof(vis));
    vis[st.x][st.y]=1;
    q.push(st);
    while(!q.empty())
    {
        tmp1=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            nx=tmp1.x+d[i][0];
            ny=tmp1.y+d[i][1];
            while(nx>=0 && nx<m && ny>=0 && ny<n && map[nx][ny]=='.')//确定一个方向一直往前走
            {
                if(!vis[nx][ny] &&tmp1.step+1<=atime)
                {
                    if(nx==dt.x && ny==dt.y)
                        return 1;
                    vis[nx][ny]=1;
                    tmp2.x=nx;
                    tmp2.y=ny;
                    tmp2.step=tmp1.step+1;
                    q.push(tmp2);
                }
                nx+=d[i][0];
                ny+=d[i][1];
            }
        }
    }
    return 0;
}
int main()
{
    int cs;
    scanf("%d",&cs);
    while(cs--)
    {
        scanf("%d%d",&m,&n);
        for(int i=0; i<m; i++)
            scanf("%s",map[i]);
        scanf("%d%d%d%d%d",&atime,&st.y,&st.x,&dt.y,&dt.x);
        atime++;//因为起始第一次转弯不算,故最大转弯次数先加一次
        st.x--;
        st.y--;
        dt.x--;
        dt.y--;
        if(bfs())
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值