Background
One day, an ant calledAlice came to an M*M chessboard. She wanted to go around all the grids. So shebegan to walk along the chessboard according to this way: (you can assume thather speed is one grid per second)
At the first second,Alice was standing at (1,1). Firstly she went up for a grid, then a grid to theright, a grid downward. After that, she went a grid to the right, then twogrids upward, and then two grids to the left…in a word, the path was like asnake.
For example, her first25 seconds went like this:
( the numbers in thegrids stands for the time when she went into the grids)
25 | 24 | 23 | 22 | 21 |
10 | 11 | 12 | 13 | 20 |
9 | 8 | 7 | 14 | 19 |
2 | 3 | 6 | 15 | 18 |
1 | 4 | 5 | 16 | 17 |
5
4
3
2
1
1 2 3 4 5
At the 8th second , she was at (2,3), and at 20thsecond, she was at (5,4).
Your task is to decide where she was at a given time.
(you can assume that M is large enough)
Input
Input file willcontain several lines, and each line contains a number N(1<=N<=2*10^9),which stands for the time. The file will be ended with a line that contains anumber 0.
Output
For each input situationyou should print a line with two numbers (x, y), the column and the row number,there must be only a space between them.
Sample Input
8
20
25
0
Sample Output
2 3
5 4
1 5
这题其实就是给定一个数,要求找出这个数在矩阵中的位置。我是先将给定的数减1,保证第N层的数字都小与N*N且大于等于(N-1)*(N-1)。然后计算该数字与N*N及(N-1)*(N-1)的距离,取较小的,然后根据其所在层数的奇偶性,输出,具体可见代码。
#include <iostream>
#include <cmath>
using namespace std;
int main() {
int num;
int order;
int p;
int q;
while (cin >> num) {
if (num == 0)
break;
num--;
order = (int)pow(num,0.5);
p = num - order * order + 1;
q = (order + 1) * (order + 1) - num;
if (order % 2)
if (p < q)
cout << p << " " << order+1 << endl;
else
cout << order+1 << " " << q << endl;
else
if (p < q)
cout << order+1 << " " << p << endl;
else
cout << q << " " << order+1 << endl;
}
return 0;
}