Ultra-QuickSort
Time Limit: 7000MS | Memory Limit: 65536K | |
Total Submissions: 32150 | Accepted: 11441 |
Description

Ultra-QuickSort produces the output
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5 9 1 0 5 4 3 1 2 3 0
Sample Output
6 0
Source
这个题比上一题更加明显,是裸的树状数组求逆序数,就是注意它的数据规模是999999999,要先进行离散化,再排序,求逆序数。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=500005;
int c[maxn],n;//存树状数组,n表示点数
int aa[maxn];//存离散化后的数组
class node
{
public:
int val,order;
};
node in[maxn];//存原始数据
//树状数组的3个函数
int lowbit(int x)
{
return x&(-x);
}
void update(int x,int val)
{
for(int i=x;i<=n;i+=lowbit(i))
{
c[i]+=val;
}
}
int getsum(int x)
{
int temp=0;
for(int i=x;i>=1;i-=lowbit(i))
{
temp+=c[i];
}
return temp;
}
bool cmp(node a,node b)
{
return a.val<b.val;
}
int main()
{
while(scanf("%d",&n)==1&&n)
{
for(int i=1;i<=n;i++) {scanf("%d",&in[i].val);in[i].order=i;}
//离散化
sort(in+1,in+n+1,cmp);
for(int i=1;i<=n;i++) aa[in[i].order]=i;
//用树状数组求逆序数
memset(c,0,sizeof(c));
long long ans=0;
for(int i=1;i<=n;i++)
{
update(aa[i],1);
ans+=i-getsum(aa[i]);
}
cout<<ans<<endl;
}
return 0;
}