HDOJ 1071 The area

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1071

题目:

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7341    Accepted Submission(s): 5138


Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.


 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
  
  
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
  
  
33.33 40.69

解题思路:

求抛物线y = ax^2 + bx + c与一条直线y=f(x)围成的区域的面积S。S = SA - SB,SA表示抛物线与直线x = x2, x = x3 , y = 0围成的区域的面积,SB表示直线x = x2, x = x3 , y = 0 与 y = f(x)围成的梯形的面积。SB = 1/2 * (y2+y3) * (x3 - x2), SA = ∫ (ax^2 + bx + c) dx (x2->x3)从x2到x3积分。我们计算一下可以得到,S = 1/6 * a * (x2 - x3)^3, 剩下来的就是要求出a了。由抛物线的性质x1 = -b / (2a), 所以b = -2ax1。建立方程组 y1 = ax1^2 - 2ax1^2 + c, y3 = ax3^2 - a2x1*x3 + c;两式相减并化简得a = (y3 - y1) / (x1 - x3)^2.最后,我们就可以得到公式S = 1/6 *(y3 - y1) * (x2 - x3) / (x1 - x3) ^ 3。ps:纯数学题,高数忘得差不多了,算公式算了好久啊。


代码:

#include <cstdio>

int main()
{
    int t;
    while(~scanf("%d", &t))
    {
        while(t--)
        {
            double x1, y1, x2, y2, x3, y3;
            scanf("%lf%lf%lf%lf%lf%lf", &x1, &y1, &x2, &y2, &x3, &y3);
            printf("%.2f\n", (y3-y1)*(x2-x3)*(x2-x3)*(x2-x3)/6.0/(x1-x3)/(x1-x3));
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值