PAT甲级1002 A+B for Polynomials(简单数组循环)

本文详细介绍了一种解决多项式加法问题的算法实现。通过输入两个多项式的非零项,包括指数和系数,该算法能够准确计算并输出这两个多项式的和。采用数组循环运算,确保结果精确到小数点后一位,适用于计算机科学与数学计算领域。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 

 简单的数组循环运算。

 

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int a,b;
	cin>>a;
	double dat[1111];
	memset(dat,0,sizeof(dat));
	double x;
	int s;
	for(int i=0;i<a;i++)
	{
		cin>>s>>x;
		dat[s]+=x;
	} 
	cin>>b;
	for(int i=0;i<b;i++)
	{
		cin>>s>>x;
		dat[s]+=x;
	}
	int js=0; 
	for(int i=0;i<=1000;i++)
	if(dat[i]!=0)js++;
	cout<<js;
	for(int i=1000;i>=0;i--)
	{
		if(dat[i]!=0)
		{
			cout<<" "<<i<<" ";
			printf("%.1lf",dat[i]);
		}
	}
	cout<<endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值