HDU1039 Easier Done Than Said?(java)

本文介绍了一个用于测试密码生成器质量的程序。该程序确保生成的密码既易记又符合特定的安全标准,包括至少包含一个元音字母、避免三个连续的元音或辅音以及除了‘ee’或‘oo’之外不允许连续重复的字符。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate “pronounceable” passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it’s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee’ or ‘oo’.

(For the purposes of this problem, the vowels are ‘a’, ‘e’, ‘i’, ‘o’, and ‘u’; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end’ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

Sample Output
is acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is acceptable.
is acceptable.

简单的字符串处理题

import java.util.Scanner;

public class P1039 {

    public static void main(String[] args) {
        new P1039().run();
    }

    public void run() {
        Scanner scanner = new Scanner(System.in);
        String str;
        while (!(str = scanner.next()).equals("end")) {
            if (isMeet1(str) && isMeet2(str) && isMeet3(str)) {
                System.out.printf("<%s> is acceptable.", str);
                System.out.println();
            }else {
                System.out.printf("<%s> is not acceptable.", str);
                System.out.println();
            }
        }
        scanner.close();
    }

    public boolean isVowel(char c) {
        if (c == 'a' || c == 'e' || c == 'i' || c == 'u' || c == 'o')
            return true;
        else
            return false;
    }

    public boolean isMeet1(String str){
        for (int i = 0; i < str.length(); i++) {
            if (isVowel(str.charAt(i))) {
                return true;
            }
        }
        return false;
    }

    public boolean isMeet2(String str){
        for (int i = 0; i < str.length() - 2; i++) {
            if(isVowel(str.charAt(i) ) && isVowel(str.charAt(i + 1))
                    && isVowel(str.charAt(i + 2))){
                return false;
            }else if(!isVowel(str.charAt(i) ) && !isVowel(str.charAt(i + 1))
                    && !isVowel(str.charAt(i + 2))){
                return false;
            }
        }
        return true;
    }

    public boolean isMeet3(String str){
        for (int i = 0; i < str.length() - 1; i++) {
            if(str.charAt(i) == str.charAt(i + 1) &&
                    str.charAt(i) != 'e' &&
                    str.charAt(i) != 'o'){
                return false;
            }
        }
        return true;
    }

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值