HDU 5512 2015ACM-ICPC沈阳赛区现场赛D题

Pagodas

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1183 Accepted Submission(s): 841

Problem Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1≤a≠b≤n) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j−k. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

Input
The first line contains an integer t (1≤t≤500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2≤n≤20000) and two different integers a and b.

Output
For each test case, output the winner (Yuwgna" orIaka”). Both of them will make the best possible decision each time.

Sample Input
16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12

Sample Output
Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka

Source
2015ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

题意
给定数字n和n个位置,a,b表示起始位置,只能选两个已走过的位置i,j,走到i+j或是i-j,
不能走的输

思路
推推规律,就能发现这题和GCD(a,b)有关,酸酸样例就过了

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int gcd(int a, int b) {
    return b ? gcd(b, a % b) : a;
}
int main() {
    int t, n, a, b;
    int cas = 1;
    scanf("%d", &t);
    while (t--) {
        printf("Case #%d: ", cas++);
        scanf("%d%d%d", &n, &a, &b);
        if (a > b)
            swap(a, b);
        int p = gcd(a, b);
        int ans = n / p;
        if (ans & 1) {
            printf("Yuwgna\n");
        } else
            printf("Iaka\n");
    }
    return 0;
}

马上就出发去杭州了,暂时先总结那么多吧
upupup!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值