POJ 3009 Curling 2.0(深搜)

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

这里写图片描述
Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
这里写图片描述
Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

这里写图片描述
Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output

1
4
-1
4
10
-1

题目大意
类似于冰壶的一个模拟游戏,搞懂其游戏规则最为重要。
1、开局石头静止处于开始的格子,它只能向着 x 和 y 方向移动,斜线移动是不允许的;
2、只有当石头静止时,游戏者才能扔出石头改变其运动状态,当石头的某个方向紧邻石块时,它朝这个方向的运动是被禁止的(开始读题被我略过的一点);
3、在石头运动时,只有当其撞到石块才会停下,且是停在石块的前一位置,石块碎掉成为可行区域;
4、当石头移动出界时,游戏失败结束;当其移动到目的地时,游戏成功结束;且要求游戏者在游戏中抛掷石头不能超过 10 次,否则失败结束。
若游戏者能成功到达目的地,输出抛掷的最小次数;否则输出-1。

解题思路
1、在石头撞到石块时,记得将石块位置改为可行区域;
2、在搜索每一个点的四个方向之前,记得先判断四个方向是否可行(是否存在紧邻的石块)。

代码实现

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int maps[26][26];
int dire[][2]= {{0,1},{0,-1},{-1,0},{1,0}};
struct node
{
    int x;
    int y;
} s,e;
int ans,w,h;
void DFS(node temp,int step)
{
    node ne;
    if(step>=10) return ;
    for(int i=0; i<4; i++)
    {
        ne.x=temp.x+dire[i][0],ne.y=temp.y+dire[i][1];
        if(maps[ne.x][ne.y]==1)
            continue;
        while(ne.x>0&&ne.x<=h&&ne.y>0&&ne.y<=w&&maps[ne.x][ne.y]==0)
        {
            ne.x+=dire[i][0];
            ne.y+=dire[i][1];
        }
        if(!(ne.x<=0||ne.x>h||ne.y<=0||ne.y>w))
        {
            if(ne.x==e.x&&ne.y==e.y)
            {
                if(step+1<ans)
                    ans=step+1;
            }
            if(maps[ne.x][ne.y]==1)
            {
                maps[ne.x][ne.y]=0;
                ne.x=ne.x-dire[i][0],ne.y=ne.y-dire[i][1];
                DFS(ne,step+1);
                maps[ne.x+dire[i][0]][ne.y+dire[i][1]]=1;
            }
        }
    }
}

int main()
{
    while(~scanf("%d %d",&w,&h))
    {
        if(w==0&&h==0) break;
        memset(maps,-1,sizeof(maps));
        ans=11;
        for(int i=1; i<=h; i++)
        {
            for(int j=1; j<=w; j++)
            {
                scanf("%d",&maps[i][j]);
                if(maps[i][j]==2)
                {
                    maps[i][j]=0;
                    s.x=i,s.y=j;
                }
                if(maps[i][j]==3)
                    e.x=i,e.y=j;
            }
        }
        DFS(s,0);
        if(ans>10)
            ans=-1;
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值