POJ 1125 Stockbroker Grapevine(最短路)

本文探讨了在特定网络结构中如何高效地传播信息,并提供了一种基于Floyd算法的解决方案,用以找出最快传播路径及起点。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their “Trusted sources” This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1’ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message “disjoint”. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
Sample Output

3 2
3 10

题目大意
股票经纪人之间进行信息的交流需要时间,现输入数据第一行代表存在 n 个股票经纪人,接下来的1…n行代表第 n 号股票经纪人与其他股票经纪人之间的信息交流,每一行的第一个数字 m 代表该股票经纪人可与 m 个股票经纪人联系,其余为 k 对数字,每一对分别代表该股票经纪人可与第几号股票经纪人进行信息交流和所需花费的时间。输出在该联系网络中从某一位股票经纪人发出信息到最后一位股票经纪人接收到信息所需的最短时间和该股票经纪人编号。

解题思路
使用 Floyd 算法求解任意两点间的最短路,然后枚举每个顶点,比较从每个顶点出发所需的最小时间,得到最终结果。如果结果值标识未被更新,那么输出disjoint。

代码实现

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 20
#define maxn 106
int map[maxn][maxn];
int x,n,to,l;
void floyd()
{
    for(int k=1;k<=x;k++)
        for(int i=1;i<=x;i++)
            for(int j=1;j<=x;j++)
            map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
}
int main()
{
    int result,t;
    while(~scanf("%d",&x))
    {
        if(x==0)break;
        memset(map,INF,sizeof(map));
        for(int i=1;i<=x;i++)
        {
            scanf("%d",&n);
            while(n--)
            {
                scanf("%d %d",&to,&l);
                map[i][to]=l;
            }
        }
        floyd();
        result=INF;
        for(int i=1;i<=x;i++)
        {
            int temp=0;
            for(int j=1;j<=x;j++)
            {
                if(i!=j)
                {
                    if(map[i][j]>temp)
                        temp=map[i][j];
                }
            }
            if(temp<result)
            {
                result=temp;
                t=i;
            }
        }
        if(result<INF)
            printf("%d %d\n",t,result);
        else
            printf("disjoint\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值