Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4
3
17 4
19 4
18 5
0
Sample Output
Scenario #1
Frog Distance = 5.000
Scenario #2
Frog Distance = 1.414
题目大意
青蛙从起点到终点进行一次或多次跳跃,求青蛙最小的需满足的最大跳跃值。
解题思路
使用 dijstra 算法的变型,最后松弛结果 d[] 不再是最短路径,而成为由起点到该点需要跳跃的最大距离。
代码实现
#include <iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
#define maxn 206
#define INF 1e8
int n;
double map[maxn][maxn],d[maxn];
struct m
{
int x,y;
}stone[maxn];
double dijkstra()
{
bool visit[maxn];
memset(visit,false,sizeof(visit));
for(int i=0;i<n;i++)
{
d[i]=map[0][i];
}
d[0]=0;
visit[0]=true;
for(int i=0;i<n-1;i++)
{
int x;
double m=INF;
for(int y=0;y<n;y++)
if(!visit[y]&&m>=d[y])
{
m=d[y];
x=y;
}
visit[x]=true;
for(int y=0;y<n;y++)
if(!visit[y])
{
double t=max(d[x],map[x][y]);
if(t<d[y]) d[y]=t;
}
}
return d[1];
}
int main()
{
int countt=0;
while(~scanf("%d",&n))
{
if(n==0)break;
for(int i=0;i<n;i++)
scanf("%d %d",&stone[i].x,&stone[i].y);
for(int i=0;i<n;i++)
{
for(int j=0;j<i;j++)
{
map[i][j]=map[j][i]=sqrt((double)(stone[i].x-stone[j].x)*(double)(stone[i].x-stone[j].x)+(double)(stone[i].y-stone[j].y)*(double)(stone[i].y-stone[j].y));
}
map[i][i]=0;
}
printf("Scenario #%d\nFrog Distance = %.3f\n\n",++countt,dijkstra());
}
return 0;
}