mod问题

题目要求:
输入正整数𝑥,𝑝(𝑥≤10^9 𝑝≤10^18)
要求输出x^𝑝 mod(10^9+7)
样例输入3 5
样例输出243

主要思路:
算法题中通常会要求对 10^9+7 取模,来避免整数溢出的问题。其中10^9+7是一个比较大的质数。通过typedef long LL;const LL num=1e9+7;和return result%num;来实现𝑚od(10^9 +7)。而x^p由一个循环来实现while(n–){result*=a;}

在这里插入图片描述

#include<iostream>
#include<stdio.h>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <map>
#include <ctime>
#include <cmath>
using namespace std;
typedef long LL;
const LL num=1e9+7;

LL power(LL a, LL n,LL result)
{
    result=1;
    while(n--)
    {
        result*=a;
    }
    return result%num;
}
int main()
{
    LL x,p;
    cout <<"输入两个正整数x、p,输出x的p次方"<< endl;
    cin>>x>>p;
    cout <<"x的p次方是:"<<power(x,p,num)<<endl;
    system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值