Longest Ordered Subsequence
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 31353 | Accepted: 13688 |
Description
A numeric sequence of
ai is ordered if
a1 <
a2 < ... <
aN. Let the subsequence of the given numeric sequence (
a1,
a2, ...,
aN) be any sequence (
ai1,
ai2, ...,
aiK), where 1 <=
i1 <
i2 < ... <
iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7 1 7 3 5 9 4 8
Sample Output
4
【时间复杂度 n^2算法】
dp【i】表示以arr【i】为结尾的最大子序列的最大长度!这里是以arr【i】为最大值的
所以答案是遍历dp,取最大值
初始 dp[] = 1;
F[i] = { F[j] +1} (j = 1, 2, ..., i - 1, if A[j] < A[i]!!!)。
#include<iostream>
#include<algorithm>
using namespace std;
int main(void){
int n;
while(cin>>n){
int * arr = new int [n];
for(int i=0;i<n;i++)
cin>>arr[i];
int * dp = new int [n];
for(int i=0;i<n;i++)
dp[i] = 1;
for(int i=0;i<n;i++){
int ans =1;
for(int j=0;j<i;j++){
if(arr[i]>arr[j]){
ans = max(ans,dp[j]+1);
}
}
dp[i] = ans;
}
int ans=dp[1];
for(int i=0;i<n;i++){
//cout<<dp[i]<<' ';
ans = max(ans,dp[i]);
}
//cout<<endl;
cout<<ans<<endl;
delete[]arr,dp;
}
return 0;
}
【nlogn 算法】
没实现。。。。百度之