Can you find it? hdu 2141

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 7954    Accepted Submission(s): 2073


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

Author
wangye
 

Source
 

Recommend
威士忌



二分
题目大意:分别给定三组A、B、C的值和S值,问是否能找到Ai、Bj、Ck,使得Ai+Bj+Ck = S。

将a数组和b数组先相加成一个数组sab[500*500]。这样就相当于sab[i] + c[j] = s。

再变形一下, sab[i] = s - c[j].
这样只要在sab数组中用二分查找是否存在s-c[j]就可以了。

#include<iostream>
#include<algorithm>
using namespace std;
int a[505],b[505],c[505],sab[250005];
bool find(int s,int b,int e)
{
    if(b>e)return false;
    int mid=(b+e)/2;
    if(sab[mid]==s)
    return true;
    else if(sab[mid]>s)
    find(s,b,mid-1);
    else
    find(s,mid+1,e);
    
}
int main()
{
    int L,N,M,S;
    int i,x,j;
    int cnt=1;
    while(scanf("%d%d%d",&L,&N,&M)!=EOF)
    {
        int k;
        for(i=0;i<N;i++)scanf("%d",&a[i]);
        for(i=0;i<M;i++)scanf("%d",&b[i]);
        for(i=0;i<L;i++)scanf("%d",&c[i]);
    
        for(k=0,i=0;i<L;i++)
            for(j=0;j<N;j++)
                sab[k++]=a[i]+b[j];
        sort(sab,sab+k);
        scanf("%d",&S);
        cout << "Case " << cnt++ << ":\n";
        for(i=0;i<S;i++)
        {
              scanf("%d",&x);
            for(j=0;j<M;j++)
            {
                if(find(x-c[j],0,k-1)) //查找是否有满足的和
                  break;
            }
                if( j == M)
                cout << "NO\n";
                else
                cout << "YES\n";
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值