Rescue

Rescue

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13
 
题意:天使的朋友就天使,中间有看守人,击败他需要消耗1,走一格消耗1,只能上下左右走。
思路:优先队列+bfs。
#include<iostream>
#include<memory.h>
#include<stdio.h>
#include<queue>
using namespace std;
typedef struct node
{
    int x;
    int y;
    int step;
}node;
char map[205][205];
int vis[205][205];
int dir[4][2]={0,1,1,0,0,-1,-1,0};
node st,end;
int n,m;
bool operator<(node a,node b)
{
    return a.step>b.step;
}
int bfs()
{
    priority_queue<node> q;
    q.push(st);
    vis[st.x][st.y]=1;
    node tmp,t;
    while(!q.empty())
    {
        tmp=q.top();
        q.pop();
        for(int i=0;i<4;i++)
        {
            int xx=tmp.x+dir[i][0];
            int yy=tmp.y+dir[i][1];
            int tt=tmp.step;
            if(xx>=0&&xx<n&&yy>=0&&yy<m&&!vis[xx][yy])
            {
                vis[xx][yy]=1;
                if(xx==end.x&&yy==end.y)
                return tt+1;
                else if(map[xx][yy]=='.')
                {
                    t.x=xx;
                    t.y=yy;
                    t.step=tt+1;
                    q.push(t);
                }
                else if(map[xx][yy]=='x')
                {
                    t.x=xx;
                    t.y=yy;
                    t.step=tt+2;
                    q.push(t);
                }
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        {
            cin>>map[i][j];
            if(map[i][j]=='r')
            {
                vis[i][j]=0;
                st.x=i;
                st.y=j;
                st.step=0;
            }
            else if(map[i][j]=='a')
            {
                vis[i][j]=0;
                end.x=i;
                end.y=j;
            }
            else if(map[i][j]=='#')
            vis[i][j]=1;
            else
            vis[i][j]=0;
        }
        int ss=bfs();
        if(ss==-1)
        cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
        else
        cout<<ss<<endl;
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值