Enclose--凸包

Description

There are n circles in a plane with equal radius. Now we wanna draw ashortest enclosed curve, and every circles lie in this curve. You have to writea program to calculate the length of this curve.

Input Description
The input contains multiple testcases.
For each case, the first line contains two integer n and r (1 ≤ n≤ 10000) denoting the number of circles and the radius of them. After that there aren lines, each line contains two integers denoting the coordinate of each circle.The absolute value of then would not be greater then 10000, and the radius is no large than 10000.
Output Description
For each case output one real number (round to 0.01) which is the length of that curve.
Sample Input
2 1
-1 0
1 0
5 1
1 0
0 1
-1 0
0 -1
0 0
Sample Output
10.28
11.94
 
真心无语了。。选拔赛的时候我带的模板中还有这道题呢。。我卡在那树深度的那道题。唉唉唉
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
#define pi acos(-1.0);
struct Point
{
	int x,y;
}point[50008],res[50008];
bool cmp(Point a,Point b)
{
	if(a.x<b.x)return 1;
	if(a.x>b.x)return 0;
	if(a.x==b.x)return a.y>b.y?0:1;
}
bool ral(Point p1,Point p2,Point p3)
{
	if((p3.y-p1.y)*(p2.x-p1.x)>(p3.x-p1.x)*(p2.y-p1.y))return 1;
	return 0;
}
double qlen(Point a,Point b)
{
	return sqrt(double((b.y-a.y)*(b.y-a.y)+(b.x-a.x)*(b.x-a.x)));
}
int main()
{
	int n,r;
	while(scanf("%d%d",&n,&r)==2)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&point[i].x,&point[i].y);
		}
		sort(point,point+n,cmp);
		int m=-1;
		for(int i=0;i<n;i++)
		{
			while(m>=1&&!ral(res[m-1],res[m],point[i]))
			{
				m--;
			}
			res[++m]=point[i];
		}
		int k=m;
		for(int i=n-2;i>=0;i--)
		{
			while(k>m&&!ral(res[k-1],res[k],point[i]))
			{
				k--;
			}
			res[++k]=point[i];
		}
		double sum=0;
		sum=2*r*pi;
		for(int i=0;i<k;i++)
		{
			sum+=qlen(res[i],res[i+1]);
		}
		printf("%.2lf\n",sum);//这里不能用llf
	}
	return 0;
}
		

标题Python网络课程在线学习平台研究AI更换标题第1章引言介绍Python网络课程在线学习平台的研究背景、意义、国内外现状和研究方法。1.1研究背景与意义阐述Python在线学习平台的重要性和研究意义。1.2国内外研究现状概述国内外Python在线学习平台的发展现状。1.3研究方法与论文结构介绍本文的研究方法和整体论文结构。第2章相关理论总结在线学习平台及Python教育的相关理论。2.1在线学习平台概述介绍在线学习平台的基本概念、特点和发展趋势。2.2Python教育理论阐述Python语言教学的理论和方法。2.3技术支持理论讨论构建在线学习平台所需的技术支持理论。第3章Python网络课程在线学习平台设计详细介绍Python网络课程在线学习平台的设计方案。3.1平台功能设计阐述平台的核心功能,如课程管理、用户管理、学习跟踪等。3.2平台架构设计给出平台的整体架构,包括前后端设计、数据库设计等。3.3平台界面设计介绍平台的用户界面设计,强调用户体验和易用性。第4章平台实现与测试详细阐述Python网络课程在线学习平台的实现过程和测试方法。4.1平台实现介绍平台的开发环境、技术栈和实现细节。4.2平台测试对平台进行功能测试、性能测试和安全测试,确保平台稳定可靠。第5章平台应用与效果分析分析Python网络课程在线学习平台在实际应用中的效果。5.1平台应用案例介绍平台在实际教学或培训中的应用案例。5.2效果评估与分析通过数据分析和用户反馈,评估平台的应用效果。第6章结论与展望总结Python网络课程在线学习平台的研究成果,并展望未来发展方向。6.1研究结论概括本文关于Python在线学习平台的研究结论。6.2研究展望提出未来Python在线学习平台的研究方向和发展建议。
### Inner-WIoUv3 的代码实现 对于 Inner-WIoUv3 的具体实现细节,在目标检测领域中,通常涉及到边界框回归损失函数的设计。基于提供的信息以及常见实践,Focal_CIoU 是一种改进的 IoU 类型损失函数,旨在解决不同尺度物体之间的定位精度差异问题[^2]。 下面是一个假设性的 Python 实现示例,用于展示如何可能实现 Inner-WIoUv3 或类似的 CIoU 变体: ```python import torch def inner_wiou_v3(pred_boxes, target_boxes, eps=1e-7): """ 计算两个矩形框间的 Inner-WIoUv3 损失 参数: pred_boxes (Tensor): 预测边框 [x_center, y_center, width, height], 形状为 N×4. target_boxes (Tensor): 目标真实边框 [x_center, y_center, width, height], 形状为 N×4. 返回: Tensor: 边界框间计算得到的平均损失值 """ # 获取预测和实际边框中心坐标及宽高 px, py, pw, ph = pred_boxes[:, 0], pred_boxes[:, 1], pred_boxes[:, 2], pred_boxes[:, 3] tx, ty, tw, th = target_boxes[:, 0], target_boxes[:, 1], target_boxes[:, 2], target_boxes[:, 3] # 计算交集区域左上角与右下角坐标 inter_xmin = torch.max(px - pw / 2, tx - tw / 2) inter_ymin = torch.max(py - ph / 2, ty - th / 2) inter_xmax = torch.min(px + pw / 2, tx + tw / 2) inter_ymax = torch.min(py + ph / 2, ty + th / 2) # 计算交集面积 inter_area = torch.clamp(inter_xmax - inter_xmin, min=0) * \ torch.clamp(inter_ymax - inter_ymin, min=0) # 计算并集面积 union_area = pw * ph + tw * th - inter_area + eps iou = inter_area / union_area # 中心点距离平方 center_dist_sq = ((px - tx)**2 + (py - ty)**2) # 外接最小水平包围盒对角线长度平方 enclose_xmin = torch.min(px - pw/2, tx - tw/2) enclose_xmax = torch.max(px + pw/2, tx + tw/2) enclose_ymin = torch.min(py - ph/2, ty - th/2) enclose_ymax = torch.max(py + ph/2, ty + th/2) diagonal_dist_sq = (enclose_xmax - enclose_xmin)**2 + \ (enclose_ymax - enclose_ymin)**2 + eps # 宽度高度比例一致性惩罚项 ratio_penalty = torch.pow((pw/tw), 2) + torch.pow((ph/th), 2) ciou_loss = 1 - iou + (center_dist_sq/diagonal_dist_sq) + ratio_penalty return ciou_loss.mean() ``` 此段代码实现了类似于 Focal_CIoU 的功能,其中包含了三个主要部分:IoU、闭包形状因子(即两中心的距离除以外接矩形对角线)、纵横比一致性的惩罚项。这些组件共同作用来衡量预测框与真值框之间匹配程度,并作为优化过程中的指导信号。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值