Given two singly linked lists L1=a1→a2→⋯→an−1→an and L2=b1→b2→⋯→b m−1→b m. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a 1→a2→bm→a3→a4→b m−1⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.
Input Specification:
Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1 and L2, plus a positive N (≤105 ) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is a positive integer no more than 1 0 5 10^5 105 , and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.
Output Specification:
For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1
Sample Output:
01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1
思路
这种pat甲级的链表的固定套路就是先用adderss作为键,存一下data和next,然后遍历一下单链表串联起来放在vector里面。接下来就是根据题意写逻辑,这里要把两个链表合二为一,模拟一下即可
cpp代码
#include<iostream>
#include<vector>
#include<unordered_map>
#include<algorithm>
using namespace std;
const int N=1e5+10;
unordered_map<int,int> da,ne;
vector<pair<int,int>> a1,b1,res;
int main(){
int h1,h2,n;
cin>>h1>>h2>>n;
for(int i=0;i<n;i++){
int b,d,e;
cin>>b>>d>>e;
da[b]=d;
ne[b]=e;
}
for(int i=h1;~i;i=ne[i])a1.push_back({i,da[i]});
for(int i=h2;~i;i=ne[i])b1.push_back({i,da[i]});
if(a1.size()<b1.size())swap(a1,b1);
reverse(b1.begin(),b1.end());
int id=0;
for(int i=0,j=0;i<a1.size()||j<b1.size();i++){
if(id==2&&j<b1.size()){
res.push_back({b1[j].first,b1[j].second});
id=0;
j++;
i--;
continue;
}
res.push_back({a1[i].first,a1[i].second});
id++;
}
for(int i=0;i<res.size();i++){
if(i!=res.size()-1)
printf("%05d %d %05d\n",res[i].first,res[i].second,res[i+1].first);
else
printf("%05d %d -1\n",res[i].first,res[i].second);
}
return 0;
}