1161 Merging Linked Lists

本文介绍了一种解决给定两个已链接列表问题的方法,当其中一个至少是另一个两倍长时,需将较短链表反转后合并到较长链表中。使用C++实现,通过地址、数据和下一个节点存储链表信息,然后根据题意编写逻辑进行操作。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given two singly linked lists L1=a1→a2→⋯→an−1→an and L2=b1→b2→⋯→b m−1→b m. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a 1→a2→bm→a3→a4→b m−1⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1 and L2, plus a positive N (≤105 ) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 1 0 5 10^5 105 , and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

思路

这种pat甲级的链表的固定套路就是先用adderss作为键,存一下data和next,然后遍历一下单链表串联起来放在vector里面。接下来就是根据题意写逻辑,这里要把两个链表合二为一,模拟一下即可

cpp代码

#include<iostream>
#include<vector>
#include<unordered_map>
#include<algorithm>
using namespace std;
const int N=1e5+10;
unordered_map<int,int> da,ne;
vector<pair<int,int>> a1,b1,res;
int main(){
    int h1,h2,n;
    cin>>h1>>h2>>n;
    for(int i=0;i<n;i++){
        int b,d,e;
        cin>>b>>d>>e;
        da[b]=d;
        ne[b]=e;
    }
    for(int i=h1;~i;i=ne[i])a1.push_back({i,da[i]});
    for(int i=h2;~i;i=ne[i])b1.push_back({i,da[i]});
  
    if(a1.size()<b1.size())swap(a1,b1);
    reverse(b1.begin(),b1.end());

   int id=0;
    for(int i=0,j=0;i<a1.size()||j<b1.size();i++){
        if(id==2&&j<b1.size()){
            res.push_back({b1[j].first,b1[j].second});
            id=0;
            j++;
            i--;
            continue;
        }
        res.push_back({a1[i].first,a1[i].second});
        id++;
    }
    for(int i=0;i<res.size();i++){
        
        if(i!=res.size()-1)
        printf("%05d %d %05d\n",res[i].first,res[i].second,res[i+1].first);
        else 
        printf("%05d %d -1\n",res[i].first,res[i].second);
    }
    return 0;
}
### IntelliJ IDEA 中通义 AI 功能介绍 IntelliJ IDEA 提供了一系列强大的工具来增强开发体验,其中包括与通义 AI 相关的功能。这些功能可以帮助开发者更高效地编写代并提高生产力。 #### 安装通义插件 为了使用通义的相关特性,在 IntelliJ IDEA 中需要先安装对应的插件: 1. 打开 **Settings/Preferences** 对话框 (Ctrl+Alt+S 或 Cmd+, on macOS)。 2. 导航到 `Plugins` 页面[^1]。 3. 在 Marketplace 中搜索 "通义" 并点击安装按钮。 4. 完成安装后重启 IDE 使更改生效。 #### 配置通义服务 成功安装插件之后,还需要配置通义的服务连接信息以便正常使用其提供的各项能力: - 进入设置中的 `Tools | Qwen Coding Assistant` 菜单项[^2]。 - 填写 API Key 和其他必要的认证参数。 - 测试连接以确认配置无误。 #### 使用通义辅助编程 一旦完成上述准备工作,就可以利用通义来进行智能编支持了。具体操作如下所示: ##### 自动补全代片段 当输入部分语句时,IDE 将自动提示可能的后续逻辑,并允许一键插入完整的实现方案[^3]。 ```java // 输入 while 循环条件前半部分... while (!list.isEmpty()) { // 激活建议列表选择合适的循环体内容 } ``` ##### 解释现有代含义 选中某段复杂的表达式或函数调用,右键菜单里会有选项可以请求通义解析这段代的作用以及优化意见。 ##### 生产测试案例 对于已有的业务逻辑模块,借助于通义能够快速生成单元测试框架及初始断言集,减少手动构建的成本。 ```python def test_addition(): result = add(2, 3) assert result == 5, f"Expected 5 but got {result}" ```
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值