**
Aaronson
**
Recently, Peter saw the equation x0+2x1+4x2+…+2mxm=n. He wants to find a solution (x0,x1,x2,…,xm) in such a manner that ∑i=0mxi is minimum and every xi (0≤i≤m) is non-negative.
Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:
The first contains two integers n and m (0≤n,m≤109).
Output
For each test case, output the minimum value of ∑i=0mxi.
Sample Input
10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3
Sample Output
1
2
2
3
2
2
3
2
3
2
题意:
给出两个整数n和m,求方程所有非负解中 sum(xi)(0<=i<=m).的最小值。
思路:
贪心,方程左边x前的系数不断上升。
代码:
#include<stdio.h>
int main()
{
int a[110],i,j,k,m,n,ans;
a[0]=1;
for(i=1;i<=30;i++)
a[i]=a[i-1]*2;
scanf("%d",&k);
while(k--)
{
scanf("%d%d",&n,&m);
if(m>30)
m=30;
ans=0;
for(i=m;i>=0;i--)
{
ans+=n/a[i];
n%=a[i];
}
printf("%d\n",ans);
}
}