Cleaning Shifts --- 贪心(区间)

**

Cleaning Shifts

**
Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:
把一天分成T班,分配奶牛,使每个时间段至少有一头奶牛,问最少多少奶牛参与,若不能分配牛到每一个时间段,则输出-1。

思路:
将开始工作时间从小到大排序,若开始时间相同,则将结束时间按从大到小排序。
若排序后第一头牛的开始时间不是1,则输出-1。
从第一头牛的最右端开始向下查找可行区间,直到覆盖t,若中间覆盖不住或所有区间全部全部遍历后,覆盖不住T,输出-1。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int s,e;
}p[252000];
bool cmp(node x,node y)
{
    if(x.s!=y.s)
        return x.s<y.s;
    return x.e>y.e;
}
int main()
{
    int n,t,i,tt;
    while(~scanf("%d%d",&n,&t)&&n!=0&&t!=0)
    {
        int ans;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&p[i].s,&p[i].e);
        }
        sort(p,p+n,cmp);
        if(p[0].s>1)//不能覆盖第一个时间段
            ans=-1;
            else
            {
                ans=1;
                tt=p[0].e;
                int nowtt=tt;
                int flag=0;
                for(i=1;i<n;i++)
                {
                    if(p[i].s<=tt+1)
                    {
                        if(p[i].e>nowtt)
                        nowtt=p[i].e;
                    if(i==n-1)
                    {
                        if(nowtt>tt)
                        {
                            tt=nowtt;
                            ans++;
                        }

                    }
                    }
                    else
                    {
                        if(nowtt>tt)//是否在确定区间内
                        {
                            tt=nowtt;
                            ans++;
                            if(tt==t)//全被覆盖
                                flag=1;
                            i--;//此区间未用
                        }
                        else
                            ans=-1;//存在没有覆盖住的时间段
                    }
                    if(flag)
                        break;
                    if(ans==-1)
                        break;

                }
            }
            if(tt!=t)
                ans=-1;
            printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值