Network of Schools

A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B
You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school.

Input

The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.

Output

Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.

Sample Input

5
2 4 3 0
4 5 0
0
0
1 0

Sample Output

1
2

 题意要求:1.至少从几个学校发射协议,可使全部学校接收到

                   2.在增加几个链接,可在任意一个学校发送协议,可到达所有学校

题解:第一问.用tarjan缩点后,缩点入度为零的点数为答案(协议从这些缩点入度为0的学校发出)。

           第二问.max(缩点后入读为0的点,缩点后出度为0的点),把出度为0的点与入度为0的点连接

#include<cstdio>
#include<stack>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=1e5+5;
stack<int>s;
vector<int>a[N];
int low[N],bfn[N],vis[N];
int tot,k,b[N],in[N],out[N];
void dfs(int x)
{
	bfn[x]=low[x]=++tot;
	vis[x]=1;
	s.push(x);
	for(int i=0; i<a[x].size(); i++)
	{
		int t=a[x][i];
		if(!bfn[t])
		{
			dfs(t);
			low[x]=min(low[x],low[t]);
		}
		else if(vis[t])low[x]=min(low[x],bfn[t]);
	}
	if(bfn[x]==low[x])
	{
		k++;
		while(!s.empty())
		{
			int t=s.top();
			s.pop();
			vis[t]=0;
			b[t]=k;
			if(t==x)break;
		}
	}
}
int main()
{
	int i,j;
	int n,x,m,y;
	cin>>n;
	for(i=1; i<=n; i++)
	{
		while(cin>>x&&x)
			a[i].push_back(x);
	}
	for(i=1; i<=n; i++)
		if(!bfn[i])
			dfs(i);
	if(k==1)
		printf("1\n0\n");
	else
	{
		for(i=1; i<=n; i++)
			for(j=0; j<a[i].size(); j++)
			{
				if(b[i]!=b[a[i][j]])
				{
					in[b[a[i][j]]]++;
					out[b[i]]++;
				}
			}
		x=0;
		y=0;
		for(i=1; i<=k; i++)
		{
			if(!in[i])x++;
			if(!out[i])y++;
		}
		printf("%d\n%d\n",x,max(x,y));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值