MPLS实验

实验要求:
1、R1与R5MPLS VPN
2、R6 与 R7MPLS VPN
3、R7可以访问R2/3/4的环回

第一步:拓扑建立

 第二步:处理公网的IP及环回

[r2]int lo0
[r2-LoopBack0]ip address 2.2.2.2 24
[r2-LoopBack0]int g0/0/1
[r2-GigabitEthernet0/0/1]ip address 23.1.1.1 24

[r3]int g0/0/1
[r3-GigabitEthernet0/0/1]ip address 34.1.1.1 24
[r3-GigabitEthernet0/0/1]int lo0
[r3-LoopBack0]ip address 3.3.3.3 24
[r3-LoopBack0]int g0/0/0
[r3-GigabitEthernet0/0/0]ip address 23.1.1.2 24

[r4]int g0/0/0
[r4-GigabitEthernet0/0/0]ip address 34.1.1.2 24
[r4-GigabitEthernet0/0/0]int lo0
[r4-LoopBack0]ip add 4.4.4.4 24
[r4-LoopBack0]int g4/0/0
[r4-GigabitEthernet4/0/0]ip address 47.1.1.1 24

[r7]int g0/0/1
[r7-GigabitEthernet0/0/1]ip address 47.1.1.2 24

第三步:处理公网的OSPF

[r2]ospf 1 router-id 2.2.2.2
[r2-ospf-1]area 0
[r2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0
[r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0

[r3]ospf 1 router-id 3.3.3.3
[r3-ospf-1]area 0
[r3-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 34.1.1.1 0.0.0.0

[r4]ospf 1 router-id 4.4.4.4
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 34.1.1.2 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 47.1.1.1 0.0.0.0
[r4-ospf-1]silent-interface GigabitEthernet 4/0/0     #将4/0/0调成沉默接口,r4与r7无需建立邻居

[r7]ip route-static 0.0.0.0 0 47.1.1.1   #r7作为客户直接写指向r4的缺省路由,则可以访问公网

第四步:启用MPLS

[r2]mpls lsr-id 2.2.2.2
[r2]mpls
Info: Mpls starting, please wait... OK!
[r2-mpls]mpls ldp	
[r2-mpls-ldp]int g0/0/1
[r2-GigabitEthernet0/0/1]mpls
[r2-GigabitEthernet0/0/1]mpls ldp

[r3]mpls lsr-id 3.3.3.3
[r3]mpls
[r3-mpls]mpls ldp
[r3-mpls-ldp]int g0/0/0
[r3-GigabitEthernet0/0/0]mpls
[r3-GigabitEthernet0/0/0]mpls ldp
[r3-GigabitEthernet0/0/0]int g0/0/1
[r3-GigabitEthernet0/0/1]mpls
[r3-GigabitEthernet0/0/1]mpls ldp

[r4]mpls lsr-id 4.4.4.4
[r4]mpls
Info: Mpls starting, please wait... OK!
[r4-mpls]mpls ldp
[r4-mpls-ldp]int g0/0/0
[r4-GigabitEthernet0/0/0]mpls
[r4-GigabitEthernet0/0/0]mpls ldp

第五步:VPN空间建立

[r2]ip vpn-instance b1   #定义一个b1空间
[r2-vpn-instance-b1]ipv4-family 
[r2-vpn-instance-b1-af-ipv4]route-distinguisher 1:1	
[r2-vpn-instance-b1-af-ipv4]vpn-target 1:1
 IVT Assignment result: 
Info: VPN-Target assignment is successful.
 EVT Assignment result: 
Info: VPN-Target assignment is successful.
[r2-vpn-instance-b1-af-ipv4]q
[r2-vpn-instance-b1]q
[r2]ip vpn-instance a1   #定义一个a1空间
[r2-vpn-instance-a1]ipv4-f	
[r2-vpn-instance-a1]ipv4-family 
[r2-vpn-instance-a1-af-ipv4]route-distinguisher 2:2
[r2-vpn-instance-a1-af-ipv4]vpn-target 2:2
 IVT Assignment result: 
Info: VPN-Target assignment is successful.
 EVT Assignment result: 
Info: VPN-Target assignment is successful.
[r2]int g0/0/0	
[r2-GigabitEthernet0/0/0]ip binding vpn-instance b1  #将接口绑定到b1上
Info: All IPv4 related configurations on this interface are removed!
Info: All IPv6 related configurations on this interface are removed!
[r2-GigabitEthernet0/0/0]ip ad 192.168.2.2 24
Feb 12 2022 17:43:13-08:00 r2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface GigabitEthernet0/0/0 has entered the UP state. 
[r2-GigabitEthernet0/0/0]int g0/0/2
[r2-GigabitEthernet0/0/2]ip binding vpn-instance a1
Info: All IPv4 related configurations on this interface are removed!
Info: All IPv6 related configurations on this interface are removed!
[r2-GigabitEthernet0/0/2]ip ad 192.168.2.2 24

[r2]bgp 1
[r2-bgp]router-id 2.2.2.2
[r2-bgp]peer 4.4.4.4 as-number 1
[r2-bgp]peer 4.4.4.4 connect-interface l	
[r2-bgp]peer 4.4.4.4 connect-interface LoopBack 0
[r2-bgp]ipv4-family vpnv4	
[r2-bgp-af-vpnv4]peer  4.4.4.4 enable   #R2和R4建立一个VPN专业的邻居关系

[r4]ip vpn-instance b2	
[r4-vpn-instance-b2]ipv4-family 
[r4-vpn-instance-b2-af-ipv4]route-distinguisher 1:1
[r4-vpn-instance-b2-af-ipv4]vpn-target 1:1
 IVT Assignment result: 
Info: VPN-Target assignment is successful.
 EVT Assignment result: 
Info: VPN-Target assignment is successful.
[r4-vpn-instance-b2-af-ipv4]q
[r4-vpn-instance-b2]q	
[r4]ip vpn-instance a2
[r4-vpn-instance-a2]ipv4-family 
[r4-vpn-instance-a2-af-ipv4]route-distinguisher 2:2
[r4-vpn-instance-a2-af-ipv4]vpn-target 2:2
 IVT Assignment result: 
Info: VPN-Target assignment is successful.
 EVT Assignment result: 
Info: VPN-Target assignment is successful.
[r4]int g0/0/1
[r4-GigabitEthernet0/0/1]ip binding vpn-instance b2
Info: All IPv4 related configurations on this interface are removed!
Info: All IPv6 related configurations on this interface are removed!
[r4-GigabitEthernet0/0/1]ip ad 192.168.3.1 24
Feb 12 2022 17:52:59-08:00 r4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface GigabitEthernet0/0/1 has entered the UP state. 
[r4-GigabitEthernet0/0/1]int g0/0/2
[r4-GigabitEthernet0/0/2]ip binding vpn-instance a2
Info: All IPv4 related configurations on this interface are removed!
Info: All IPv6 related configurations on this interface are removed!
[r4-GigabitEthernet0/0/2]ip address 192.168.3.1 24

[r4]bgp 1
[r4-bgp]router-id 4.4.4.4
[r4-bgp]peer 2.2.2.2 as-number 1	
[r4-bgp]peer 2.2.2.2 connect-interface LoopBack 0
[r4-bgp]ipv4-family vpnv4
[r4-bgp-af-vpnv4]peer 2.2.2.2 enable 

第六步:路由器配置私网IP及环回

[r1]int lo0
[r1-LoopBack0]ip ad 192.168.1.1 24
[r1-LoopBack0]int g0/0/1
[r1-GigabitEthernet0/0/1]ip ad 192.168.2.1 24

[r6]int lo0
[r6-LoopBack0]ip ad 192.168.1.1 24
[r6-GigabitEthernet0/0/2]int g0/0/0
[r6-GigabitEthernet0/0/0]ip ad 192.168.2.1 24

[r5]int lo0
[r5-LoopBack0]ip ad 192.168.4.1 24
[r5-LoopBack0]int g0/0/0
[r5-GigabitEthernet0/0/0]ip ad 192.168.3.2 24

[r7]int g0/0/0
[r7-GigabitEthernet0/0/0]ip ad 192.168.3.2 24
[r7-GigabitEthernet0/0/0]int lo0
[r7-LoopBack0]ip ad 192.168.4.2 24

第七步:在R2上和R6上跑RIP协议,在R4和R7上跑OSPF协议并在R2和R4上进行双向重发布

[r6]rip 1
[r6-rip-1]ver 2
[r6-rip-1]network 192.168.1.0
[r6-rip-1]network 192.168.2.0

[r2]rip vpn-instance a1
[r2-rip-1]ver 2
[r2-rip-1]network 192.168.2.0

[r7]ospf 1 router-id 7.7.7.7
[r7-ospf-1]area 0
[r7-ospf-1-area-0.0.0.0]network 192.168.3.2 0.0.0.0
[r7-ospf-1-area-0.0.0.0]network 192.168.4.2 0.0.0.0

[r4]ospf 2 vpn-instance a2
[r4-ospf-2]area 0
[r4-ospf-2-area-0.0.0.0]network 192.168.3.1 0.0.0.0

[r2]rip 1 vpn-instance a1            #在R2上进行双向重发布
[r2-rip-1]import-route bgp
[r2-rip-1]q
[r2]bgp 1
[r2-bgp]ipv4-family vpn-instance a1	
[r2-bgp-a1]import-route rip 1

[r4]bgp 1                          #在R4上进行双向重发布
[r4-bgp]ipv4-family vpn-instance a2
[r4-bgp-a2]import-route ospf 2
[r4-bgp-a2]q
[r4-bgp]q	
[r4]ospf 2 vpn-instance a2
[r4-ospf-2]import-route bgp

测试:

 

第八步:手动配置静态路由条目

[r1]ip route-static 192.168.3.0 24 192.168.2.2
[r1]ip route-static 192.168.4.0 24 192.168.2.2

[r2]ip route-static vpn-instance b1 192.168.1.0 24 192.168.2.1
[r2]bgp 1         #R2将这边的静态路由发布到R4
[r2-bgp]ipv4-family vpn-instance b1
[r2-bgp-b1]import-route static 
[r2-bgp-b1]import-route direct 

[r4]ip route-static vpn-instance b2 192.168.4.0 24 192.168.3.2
[r4]bgp 1
[r4-bgp]ipv4-family vpn-instance b2
[r4-bgp-b2]import-route direct 	
[r4-bgp-b2]import-route static 

[r5]ip route-static 192.168.1.0 24 192.168.3.1
[r5]ip route-static 192.168.2.0 24 192.168.3.1

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值